File gedit-plugins.changes of Package gedit-plugins

-------------------------------------------------------------------
Tue Mar 24 08:54:54 UTC 2015 - dimstar@opensuse.org

- Update to version 3.16.0:
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Mon Mar 23 15:21:40 UTC 2015 - badshah400@gmail.com

- Main package should Suggest instead of Recommending individual
  plugin packages; split Provides for individual plugin
  subpackages to help with update.

-------------------------------------------------------------------
Tue Mar 17 18:23:56 UTC 2015 - sfalken@opensuse.org

-  Reworked subpackages, to provide for individual installation of
   plugins, rather than getting all or nothing.

-------------------------------------------------------------------
Mon Mar 16 09:06:27 UTC 2015 - dimstar@opensuse.org

- Update to version 3.15.1:
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Wed Feb 18 19:06:57 UTC 2015 - dimstar@opensuse.org

- Update to version 3.15.0:
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Mon Feb  9 20:19:15 UTC 2015 - zaitor@opensuse.org

- Move zeitgeist Requires to the gedit-plugin-zeitgeist
  sub-package, avoid dragging in zeitgeist for main package.

-------------------------------------------------------------------
Thu Nov 13 20:31:14 UTC 2014 - zaitor@opensuse.org

- Update to version 3.14.1:
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Tue Sep 23 10:14:56 UTC 2014 - dimstar@opensuse.org

- Update to version 3.14.0:
  + New features and fixes:
    - Improve joinlines plugin.
    - Improve multiedit plugin.
    - Improve commander plugin.
    - Improve git plugin.
    - terminal: Port to vte-2.91.
  + Updated translations.
- Drop gedit-plugins-vte-2.91.patch: fixed upstream.
- Drop gnome-common BuildRequires and call to autogen.sh: no longer
  requires, as no patch touches the build system.
- Add typelib-1_0-Gucharmap-2_90 BuildRequires: new dependency. As
  the plugins are written in python, we only require the gi
  bindings, not the entire -devel package.

-------------------------------------------------------------------
Sat Jul 26 16:21:25 UTC 2014 - dimstar@opensuse.org

- Update to version 3.13.2:
  + Adapt to the rename of gedit's desktop file.

-------------------------------------------------------------------
Tue Jul 22 21:09:21 UTC 2014 - dimstar@opensuse.org

- Update to version 3.13.1:
  + Adapt the plugins for the changes in GeditDocument.
  + Various improvements and bug fixes.
  + Updated translations.

-------------------------------------------------------------------
Sat Jul 12 22:29:02 UTC 2014 - dimstar@opensuse.org

- Update to version 3.13.0:
  + Moved zeitgeist plugin from gedit core to plugins.
  + Updated translations.
- Add pkgconfig(zeitgeist-2.0) BuildRequires.
- Create new subpackage gedit-plugin-zeitgeist (moved from gedit
  mainpackage, preserved the name of the package).
- Add gedit-plugins-vte-2.91.patch: Detect and use Vte 2.91.
- Add gnome-common BuildRequires and call to autogen.sh, as above
  patch touches the buildsystem.
- Replace pkgconfig(vte-2.90) BuildRequires with
  pkgconfig(vte-2.91).

-------------------------------------------------------------------
Mon Apr 14 20:03:14 UTC 2014 - zaitor@opensuse.org

- Update to version 3.12.1:
  + Split drawspaces into app/window/view activatables.
  + Fix bug preventing synctex to work.
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Mon Mar 24 20:03:14 UTC 2014 - zaitor@opensuse.org

- Update to version 3.12.0:
  + Ignore remote files in the git plugin.
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Wed Mar  5 09:09:26 UTC 2014 - dimstar@opensuse.org

- Update to version 3.11.91:
  + Port synctex to new menu API.
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Thu Feb  6 18:09:08 UTC 2014 - dimstar@opensuse.org

- Update to version 3.11.2:
  + Port plugins to new menu API.
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Wed Jan 15 12:35:12 UTC 2014 - dimstar@opensuse.org

- Update to version 3.11.1:
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Wed Dec  4 19:34:14 UTC 2013 - dimstar@opensuse.org

- Update to version 3.10.1:
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Mon Sep 23 19:24:52 UTC 2013 - dimstar@opensuse.org

- Update to version 3.10.0:
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Sat Jul 20 09:16:50 UTC 2013 - dimstar@opensuse.org

- Update to version 3.9.2:
  + Show the file's git status in the file browser.
  + Word completion: add configure options.
  + Misc bugfixes.
  + Updated translations.
- Add pkgconfig(libgit2-glib-1.0) BuildRequires: enable the git
  plugin.

-------------------------------------------------------------------
Fri Jun 21 19:50:58 UTC 2013 - dimstar@opensuse.org

- Update to version 3.9.1:
  + Add user help translations.
  + New git plugin.
  + terminal: handle drag and drop of files.
  + Follow gnome-terminal settings on terminal plugin.
  + Misc bugfixes.
  + Updated translations.
- Replace gnome-doc-utils-devel BuildRequires with yelp-tools,
  following upstreams port to the new documentation infrastructure.

-------------------------------------------------------------------
Sun May 26 18:42:07 UTC 2013 - dimstar@opensuse.org

- Update to version 3.8.2:
  + Follow gnome-terminal settings on terminal plugin.
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Mon Apr 15 17:33:04 UTC 2013 - dimstar@opensuse.org

- Update to version 3.8.1:
  + Port Dashboard to use libzeitgeist2.
  + New Color Schemer plugin.
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Mon Mar 25 20:35:23 UTC 2013 - dimstar@opensuse.org

- Update to version 3.8.0:
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Tue Feb  5 19:56:57 UTC 2013 - dimstar@opensuse.org

- Update to version 3.7.1:
  + Port plugins to python 3.
  + Drop session saver plugin.
  + Drop taglist plugin.
  + Misc bugfixes.
  + Updated translations.

-------------------------------------------------------------------
Tue Oct 16 15:04:20 UTC 2012 - dimstar@opensuse.org

- Update to version 3.6.1:
  + Misc bugfixes.
  + Updated translations.
- Fix the fdupes calls: it's been a while gedit-2 did not exist
  anymore.

-------------------------------------------------------------------
Mon Sep 24 20:57:25 UTC 2012 - dimstar@opensuse.org

- Update to version 3.6.0:
  + Use the textview instead of the overlay for the overlayed color
    button.

-------------------------------------------------------------------
Wed Sep 19 18:19:12 UTC 2012 - dimstar@opensuse.org

- Update to version 3.5.2:
  + Color picker now shows an overlayed color button when a
    hexadecimal color is selected
  + Misc bugfixes
  + Updated translations.

-------------------------------------------------------------------
Sun Aug 19 11:05:09 UTC 2012 - dimstar@opensuse.org

- Update to version 3.5.1:
  + Misc bugfixes
  + Updated translations.

-------------------------------------------------------------------
Mon Apr 23 08:08:38 UTC 2012 - vuntz@opensuse.org

- Update to version 3.4.0:
  + Misc bugfixes
  + Updated translations.
- Drop gedit-plugins-implicit.patch: fixed upstream.

-------------------------------------------------------------------
Thu Mar  8 17:05:34 UTC 2012 - vuntz@opensuse.org

- Update to version 3.3.4:
  + Port colorpicker to new color chooser widget
  + Use GResource for drawspaces
  + Misc bugfixes
  + Updated translations.

-------------------------------------------------------------------
Sat Feb 25 10:25:20 UTC 2012 - vuntz@opensuse.org

- Update to version 3.3.3:
  + Misc bugfixes
  + Updated translations.
- Remove sed hack in %prep for broken configure check for vte:
  fixed upstream.

-------------------------------------------------------------------
Tue Feb  7 11:01:50 UTC 2012 - vuntz@opensuse.org

- Update to version 3.3.2:
  + Commander plugin bugfixes
  + Misc bugfixes
  + Updated translations.
- Remove xz BuildRequires now that it comes for free in the build
  system.
- Add pkgconfig(vte-2.90) BuildRequires to keep building the
  terminal plugin, after a configure check got added for vte.
- Add a sed hack in %prep to work around broken configure check for
  vte.

-------------------------------------------------------------------
Wed Dec 21 14:23:43 UTC 2011 - vuntz@opensuse.org

- Add zeitgeist Requires for the dashboard plugin.
- Remove .la files: we're not interested in them.
- Explicitly list all plugins in the file list, so we notice if
  we're missing one.

-------------------------------------------------------------------
Sun Dec  4 13:14:29 UTC 2011 - dimstar@opensuse.org

- Update to version 3.3.1:
  + New dashboard plugin
  + Misc bugfixes
  + Updated translations.
- Add xz BuildRequires because we can't build a package for a
  xz-compressed tarball without explicitly specifying that... See
  bnc#697467 for more details.
- Add gedit-plugins-implicit.patch: Fix an implicit declaration of
  atoi(), as stdlib.h was not included.
- Change License tag to spdx identifier (GPL-2.0+).

-------------------------------------------------------------------
Mon Oct 17 06:00:28 UTC 2011 - vuntz@opensuse.org

- Update to version 3.2.1:
  + i18n fixes
  + Fix doc module in commander plugin
  + Misc bugfixes
  + Updated translations.

-------------------------------------------------------------------
Mon Sep 26 20:36:20 UTC 2011 - vuntz@opensuse.org

- Update to version 3.2.0:
  + Updated translations.

-------------------------------------------------------------------
Fri Sep 23 17:48:15 UTC 2011 - andrea.turrini@gmail.com

- Fix typo in description.

-------------------------------------------------------------------
Wed Sep 21 11:17:31 UTC 2011 - vuntz@opensuse.org

- Update to version 3.1.5:
  + Misc bugfixes
  + Updated translations.

-------------------------------------------------------------------
Tue Sep  6 14:22:53 UTC 2011 - vuntz@opensuse.org

- Update to version 3.1.4:
  + Misc bugfixes

-------------------------------------------------------------------
Thu Sep  1 14:09:58 UTC 2011 - vuntz@opensuse.org

- Update to version 3.1.3:
  + Misc bugfixes
  + Updated translations.

-------------------------------------------------------------------
Tue Jul  5 15:32:20 CEST 2011 - vuntz@opensuse.org

- Update to version 3.1.2:
  + Misc bugfixes.

-------------------------------------------------------------------
Tue Jun 14 09:30:13 CEST 2011 - dimstar@opensuse.org

- Update to version 3.1.1:
  + Misc bugfixes
  + Updated translations.

-------------------------------------------------------------------
Fri May 27 10:25:24 CEST 2011 - dimstar@opensuse.org

- Update to version 3.0.3:
  + Misc bugfixes.

-------------------------------------------------------------------
Wed Apr 27 13:05:37 UTC 2011 - fcrozat@novell.com

- Update to version 3.0.2:
  + Misc bugfixes
  + Updated translations.
- Changes from version 3.0.1:
  + Misc bugfixes

-------------------------------------------------------------------
Wed Apr  6 09:07:13 UTC 2011 - fcrozat@novell.com

- Update to version 3.0.0:
  - Port commander plugin to gtk+ 3.

-------------------------------------------------------------------
Tue Mar 29 11:28:11 UTC 2011 - fcrozat@novell.com

- Update to version 2.91.3:
  + Update autoconf
  + Port bookmarks plugin to new message bus system
  + Update synctex to use the new dbus api
  + Misc Bugfixes
- Changes from version 2.91.2:
  + Misc bugfixes
- Changes from version 2.91.1:
  + Several plugins ported to gtk3/libpeas
  + Port charmap plugin to python.
  + Import the taglist plugin from gedit
  + Added new 'grep' commander module
  + Added synctex plugin
  + Misc Bugfixes
- Changes from version 2.90.0:
  + Ported textsize plugin to libpeas.
  + Update several plugins to new libpeas API.
- Move to pkgconfig()-style BuildRequires (including move to GNOME
  3 stack):
  + Old ones: gedit-devel, gtk2-devel, gtksourceview-devel.
  + New ones: gedit, gtk+-3.0, gtksourceview-3.0.
- Add pkgconfig() BuildRequires: dbus-python (for synctex plugin)
  and libpeas-gtk-1.0.
- Drop BuildRequires: gconf2-devel (move to GSettings), glib2-devel
  (implied by gtk3), gucharmap-devel, python-gtk-devel,
  python-gtksourceview-devel, vte-devel (move to libpeas-based
  plugins).
- Replace GConf2 schemas handling with GSettings schemas handling,
  with %glib2_gsettings_schema_* macros.

-------------------------------------------------------------------
Mon Feb 21 12:40:28 CET 2011 - vuntz@opensuse.org

- Fix build, now that translation-update-upstream introduces the
  sr@latin translation. So we simply need to remove sr@Latn,
  instead of renaming it to sr@latin.

-------------------------------------------------------------------
Tue Sep 28 20:35:41 CEST 2010 - vuntz@opensuse.org

- Update to version 2.32.0:
  + Updated translations.

-------------------------------------------------------------------
Sat Sep 18 10:51:36 CEST 2010 - vuntz@opensuse.org

- Update to version 2.31.7:
  + Misc fixes to synctex plugin.
- Changes from version 2.31.6:
  + Misc fixes to synctex plugin.
  + Misc fixes to commander and multiedit plugins.
  + Added new texsize plugin
  + Updated translations.
- Changes from version 2.31.5:
  + Added new synctex plugin.
- Changes from version 2.31.4 and earlier were discarded and will
  be in the 3.0 release.

-------------------------------------------------------------------
Fri Jun  4 17:03:23 CEST 2010 - sbrabec@suse.cz

- Added support for translation-update-upstream (FATE#301344).

-------------------------------------------------------------------
Wed May 12 14:17:02 UTC 2010 - dimstar@opensuse.org

- Choose valid RPM group.

-------------------------------------------------------------------
Thu Apr  1 13:45:39 CEST 2010 - vuntz@opensuse.org

- Remove unneeded gedit BuildRequires, since gedit-devel now brings
  it in.

-------------------------------------------------------------------
Tue Mar 30 00:19:26 CEST 2010 - vuntz@opensuse.org

- Update to version 2.30.0:
  + Commander:
    - change shortcut to control-+
    - hide commander when done
    - add autocomplete for edit.rename
    - make shell background and replace also accessible from the
      module
    - improve new-command template
    - implement support for accelerators
    - allow completion of empty command
    - various bug fixes
  + Add new align module
  + Updated translations.pdated translations.

-------------------------------------------------------------------
Sun Jan 17 04:35:24 CET 2010 - vuntz@opensuse.org

- Update to version 2.29.4:
  + Added new plugin commander
  + Added message bus bindings for bookmarks actions
  + Misc Bugfixes
  + Updated translations.
- Use fdupes on /usr/share/gedit-2 too.

-------------------------------------------------------------------
Thu Dec  3 00:41:14 CET 2009 - vuntz@opensuse.org

- Update to version 2.29.3:
  + Misc Bugfixes
  + Updated translations.
- Changes from version 2.29.2:
  + Added multi edit plugin
  + Misc Bugfixes
  + Updated translations.
- Changes from version 2.29.1:
  + Added word completion plugin
  + Added support for drawing leading, text and trailing spaces
  + Misc Bugfixes
  + Updated translations.

-------------------------------------------------------------------
Thu Oct  1 17:38:19 CEST 2009 - vuntz@opensuse.org

- Update to version 2.28.0:
  + Misc Bugfixes
  + Updated translations.

-------------------------------------------------------------------
Wed Aug 26 10:33:28 CEST 2009 - vuntz@novell.com

- Update to version 2.27.1:
  + Remember bookmarks on files using metadata
  + Misc Bugfixes
  + Updated translations.

-------------------------------------------------------------------
Fri Jul 31 12:29:14 CEST 2009 - vuntz@novell.com

- Update to version 2.26.3:
  + Misc bugfixes
  + Updated translations.

-------------------------------------------------------------------
Tue May 19 10:00:50 CEST 2009 - dominique-obs@leuenberger.net

- Update to version 2.26.2:
  + Misc bugfixes
  + Updated translations.

-------------------------------------------------------------------
Mon May 18 03:36:20 CEST 2009 - vuntz@novell.com

- Do not use tabs, remove trailing white spaces.
- Add missing Requires for the lang package.
- Fix the sr@Latn with a simple mv, instead of patching.
- Use fdupes.
- Add Requires on gedit.

-------------------------------------------------------------------
Sat May 16 22:41:30 CEST 2009 - dominique-obs@leuenberger.net

- New package for gedit-plugins, all plugins enabled.