File libgadu.changes of Package libgadu

-------------------------------------------------------------------
Tue Feb  3 18:09:54 UTC 2015 - fisiu@opensuse.org

- Update to version 1.12.1, bugfix release:
  + improved compatibility with GG11 protocol
  + fix segfaults when got incorrect reply from public catalog
  + fixes related to proxy servers

-------------------------------------------------------------------
Tue Jun 17 23:14:00 UTC 2014 - twasilczyk@pidgin.im

- Update to version 1.12.0:
  + supports GG11 protocol
  + important SSL-related API improvements
  + OpenSSL is disabled by default
  + pthread is a default hostname resolving method now
  + stability improvements
- Updated dependencies
  + libgsm and speex are not used at all
  + libexpat, libcurl and libxml are used only for automatic tests
  + libprotobuf-c is an optional dependency
- Removed unnecessary --with-pthread switch (it's default now)

-------------------------------------------------------------------
Sun May 11 20:55:42 UTC 2014 - fisiu@opensuse.org

- Update to version 1.11.4, bugfix release:
  + Fix buffer overflow with remote code execution potential.
    Only triggerable by a Gadu-Gadu server or a man-in-the-middle.
    CVE-2013-6487 (bnc#861019, bnc#878540)
  + Fix memory overwrite in file transfer with proxy server.
    CVE-2014-3775 (bnc#878540)
  + Minor fixes reported by Pidgin project members.

-------------------------------------------------------------------
Tue Jun 19 14:38:52 UTC 2012 - fisiu@opensuse.org

- Update to version 1.11.2, bugfix release:
  + improved hostname resolving in singlethread applications.

-------------------------------------------------------------------
Thu Jan 19 12:51:45 UTC 2012 - fisiu@opensuse.org

- Update to version 1.11.1, bugfix release:
  + improved SSL support with GnuTLS library
  + improved pkg-config handling
  + improved conversion of invalid UTF-8 sequence
  + improved hostname resolving on systems without gethostbyname_r()

-------------------------------------------------------------------
Fri Dec 30 19:09:30 CET 2011 - sbrabec@suse.cz

- Apply /usr/local include work-around for 12.1 only (bnc#719176).

-------------------------------------------------------------------
Mon Dec  5 21:15:12 UTC 2011 - fisiu@opensuse.org

- Fix include path (/usr/local) in .pc file.
- Replace -devel with pkgconfig() in BuildRequires.
- Fix license notation according to spdx.

-------------------------------------------------------------------
Fri Jun 17 03:50:17 CEST 2011 - vuntz@opensuse.org

- Change pkgconfig(openssl) BuildRequires to gnutls-devel as this
  seems to be preferred.
- Add curl-devel, libexpat-devel, libgsm-devel, speex-devel and
  pkgconfig(libxml-2.0) BuildRequires, to enable optional features.

-------------------------------------------------------------------
Thu Jun  9 12:42:15 UTC 2011 - fisiu@opensuse.org

- Update to version 1.11.0:
  + contacts import/export compatible with gadu-gadu 10
  + improved sockets management with direct connections
  + detailed report when connection fails
  + enhanced confirmation for delivered message
  + improved message conversion from html to plain text

-------------------------------------------------------------------
Fri Mar 18 16:36:38 UTC 2011 - fisiu@opensuse.org

- Update to version 1.10.1:
  + improved direct connections
  + improved connections over proxy server
  + some minor changes

-------------------------------------------------------------------
Fri Feb 18 16:11:55 UTC 2011 - fisiu@opensuse.org

- Update to version 1.10.0:
  + ssl connections restored
  + typing notifications
  + multilogin support
  + buddies' info enhancement
  + support for additional xml events
  + initial file transfer over server
  + partial import of new-api branch
- Spec cleanup. 

-------------------------------------------------------------------
Sat Oct  9 10:08:03 UTC 2010 - fisiu@opensuse.org

- Update to version 1.9.1:
  + fixed memory leak in html messages
  + improved converting messages to html
  + status flag can be changed now
  + improved direct connection API
- Drop libgadu-mem-leak-fix.patch: fixed upstream.

-------------------------------------------------------------------
Sun May 23 22:34:22 UTC 2010 - fisiu@opensuse.org

- Update to version 1.9.0:
  + support for new version of gadu-gadu protocol (8 and 10)
  + images sending fixed
  + resolve name schema option
  + doc and test programs
- Add libgadu-mem-leak-fix.patch.

-------------------------------------------------------------------
Mon Jul 27 15:54:18 CEST 2009 - sbrabec@suse.cz

- Build with threads support (bnc#525312) and SSL support.

-------------------------------------------------------------------
Wed Oct 29 14:10:02 CET 2008 - sbrabec@suse.cz

- Updated to version 1.8.2:
  * fixes remote denial of service via contact description
    (CVE-2008-4776, bnc#439770)

-------------------------------------------------------------------
Tue Aug 19 13:22:15 CEST 2008 - sbrabec@suse.cz

- Updated to version 1.8.1:
  * fixed memory corruption in gg_dcc7_send_file()
  * fixes in sending cached data
  * endian fixes
  * documentation fixes

-------------------------------------------------------------------
Sat Mar  8 18:04:41 CET 2008 - crrodriguez@suse.de

- update to version 1.8.0
  * using protocol Gadu-Gadu 7.x
  * direct connection fixes
  * minor fixes
- disable static libraries

-------------------------------------------------------------------
Fri May 11 07:01:34 CEST 2007 - aj@suse.de

- Remove duplicate post/postun sections.

-------------------------------------------------------------------
Thu May 10 17:52:07 CEST 2007 - sbrabec@suse.cz

- New SuSE package, version 1.7.1.