File perl-Role-Tiny.changes of Package perl-Role-Tiny

-------------------------------------------------------------------
Thu May  5 10:03:54 UTC 2016 - coolo@suse.com

- updated to 2.000003
   see /usr/share/doc/packages/perl-Role-Tiny/Changes

  2.000003 - 2016-04-21
    - don't install subs if importing into a package that is already a role.  This
      can happen if the module previously imported Moo::Role.
  
  2.000002 - 2016-04-19
    - restore compatibility with Moo versions pre 1.004_003
    - delay loading Class::Method::Modifiers until applying modifiers to a package
    - use croak rather than die for reporting errors
    - apply method modifiers only once, even if they are applied via multiple
      composition paths (RT#106668)

-------------------------------------------------------------------
Sat Apr 25 07:34:36 UTC 2015 - coolo@suse.com

- updated to 2.000001
   see /usr/share/doc/packages/perl-Role-Tiny/Changes

  2.000001 - 2015-04-24
    - fix generating invalid package names with single colons when abbreviating
      long package names (RT#103310)
    - don't run module interaction tests for user installs

-------------------------------------------------------------------
Tue Apr 14 21:02:27 UTC 2015 - coolo@suse.com

- updated to 2.000000
   see /usr/share/doc/packages/perl-Role-Tiny/Changes

  2.000000 - 2015-02-26
    * Incompatible Changes
      - Role::Tiny no longer applies fatal warnings to roles created with it.
        strict and non-fatal warnings will continue to be applied.

-------------------------------------------------------------------
Wed Nov 12 09:38:14 UTC 2014 - coolo@suse.com

- updated to 1.003004
  - allow does_role to be overridden by Moo::Role

-------------------------------------------------------------------
Mon Jul 28 10:08:32 UTC 2014 - coolo@suse.com

- updated to 1.003003
   - overloads specified as method names rather than subrefs are now applied
     properly
   - allow superclass to provide conflicting methods (RT#91054)
   - use ->is_role internally to check if a package is a role
   - document that Role::Tiny applies strict and fatal warnings

-------------------------------------------------------------------
Fri Oct  4 09:13:59 UTC 2013 - coolo@suse.com

- updated to 1.003002
  - abbreviate generated package names if they are longer than perl can handle
    (RT#83248)
  - add explicit dependency on the version of Exporter that added 'import'

-------------------------------------------------------------------
Fri Jul 26 05:36:47 UTC 2013 - coolo@suse.com

- updated to 1.003001
  - allow composing roles simultaneously that mutually require each other
    (RT#82711)
  - Fix _concrete_methods_of returning non-CODE entries
  - fix broken implementation of method conflict resolution
    (Perlmonks#1041015)
  - add is_role method for checking if a given package is a role
  - drop minimum perl version - code tests just fine on 5.6.1 and 5.6.2

-------------------------------------------------------------------
Wed Jun 26 11:22:59 UTC 2013 - coolo@suse.com

- initial package 1.002005
    * created by cpanspec 1.78.06