File python-atspi.spec of Package python-atspi

#
# spec file for package python-atspi
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define build_for_python3 0

%if %{build_for_python3}
%define local_py_requires Requires: python(abi) = %py3_ver
%define local_py_sitedir  %{python3_sitearch}
%define local_py_sitelib  %{python3_sitelib}
%define local_py_suffix   3
%define local_py_pkg      python3
%define local_lib_ver     3-0
%else
%define local_py_requires %{py_requires}
%define local_py_sitedir  %{py_sitedir}
%define local_py_sitelib  %{python_sitelib}
%define local_py_suffix   2
%define local_py_pkg      python
%define local_lib_ver     2-0
%endif

Name:           python-atspi
%define _name   pyatspi
Version:        2.20.2
Release:        0
Summary:        Assistive Technology Service Provider Interface - Python bindings
License:        LGPL-2.0
Group:          Development/Libraries/Python
Url:            http://www.gnome.org/
Source0:        http://download.gnome.org/sources/pyatspi/2.20/%{_name}-%{version}.tar.xz
BuildRequires:  fdupes
# Needed to have typelib() Requires.
BuildRequires:  gobject-introspection
BuildRequires:  pkgconfig(pygobject-3.0) >= 2.90.1
%if %{build_for_python3}
Requires:       dbus-1-python3
Requires:       python3-gobject
%else
Requires:       dbus-1-python
Requires:       python-gobject
%endif
# The bindings are really useful only if the at-spi registry is running. But
# it's not a strict runtime dependency.
Recommends:     at-spi2-core
# Virtual package, so that apps can depend on it, without having to know which
# at-spi stack is used. Only the default at-spi stack should define it.
%if %{build_for_python3}
Provides:       py3atspi
%else
Provides:       pyatspi
%endif
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
# Old versions of at-spi 1.x provided the same files
Conflicts:      at-spi < 1.29.3
%py_requires

%description
AT-SPI is a general interface for applications to make use of the
accessibility toolkit. This version is based on dbus.

This package contains the python bindings for AT-SPI.

%prep
%setup -q -n %{_name}-%{version}

%build
%if %{build_for_python3}
export PYTHON=python3
%endif
%configure
make %{?_smp_mflags}

%install
%make_install
%fdupes %{buildroot}%{local_py_sitelib}

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root)
%doc AUTHORS COPYING README
%{local_py_sitelib}/pyatspi/

%changelog