File python3-atspi.changes of Package python-atspi

-------------------------------------------------------------------
Fri May 20 22:04:05 UTC 2016 - mgorse@suse.com

- Update to GNOME 3.20.2  Fate#318572

-------------------------------------------------------------------
Tue May 10 20:52:20 UTC 2016 - zaitor@opensuse.org

- Update to version 2.20.2:
  + Update STATE_LAST_DEFINED so that STATE_READ_ONLY is recognized
    (bgo#766121).

-------------------------------------------------------------------
Thu Apr 14 13:08:31 UTC 2016 - mgorse@suse.com

- Update to GNOME 3.20  Fate#318572

-------------------------------------------------------------------
Tue Apr 12 11:54:19 UTC 2016 - zaitor@opensuse.org

- Update to version 2.20.1:
  + gettext: Don't modify endOffset (bgo#721860).

-------------------------------------------------------------------
Tue Mar 22 09:59:34 UTC 2016 - dimstar@opensuse.org

- Update to version 2.20.0:
  + No changes, stable release.

-------------------------------------------------------------------
Tue Mar  1 12:30:48 UTC 2016 - zaitor@opensuse.org

- Update to version 2.19.91:
  + Call gi.require_version() before import.

-------------------------------------------------------------------
Tue Sep 22 06:47:24 UTC 2015 - dimstar@opensuse.org

- Update to version 2.18.0:
  + No changes, stable release.

-------------------------------------------------------------------
Mon Aug 17 21:04:29 UTC 2015 - zaitor@opensuse.org

- Update to version 2.17.90:
  + Fix text.getDefaultAttributeSet (bgo#752928).

-------------------------------------------------------------------
Tue Mar 24 21:35:01 UTC 2015 - zaitor@opensuse.org

- Update to version 2.16.0:
  + No changes, stable bump.

-------------------------------------------------------------------
Tue Feb 17 13:37:37 UTC 2015 - dimstar@opensuse.org

- Update to version 2.15.90:
  + Add new roles for fractions, roots, subscripts, and
    superscripts (bgo#743413).

-------------------------------------------------------------------
Wed Jan 28 22:07:36 UTC 2015 - zaitor@opensuse.org

- Update to version 2.15.4:
  + Support ATSPI_STATE_READ_ONLY (bgo#690108).

-------------------------------------------------------------------
Thu Dec 18 02:35:58 UTC 2014 - zaitor@opensuse.org

- Update to version 2.15.3:
  + Add ROLE_STATIC (bgo#740364).

-------------------------------------------------------------------
Mon Sep 22 17:15:30 UTC 2014 - zaitor@opensuse.org

- Update to version 2.14.0:
  + Test fixes.

-------------------------------------------------------------------
Tue Mar 25 13:59:22 UTC 2014 - dimstar@opensuse.org

- Update to version 2.12.0:
  + Stable release, no changes since 2.11.92.

-------------------------------------------------------------------
Wed Mar 19 14:48:33 UTC 2014 - dimstar@opensuse.org

- Update to version 2.11.92:
  + Fix a traceback when removing a text selection.

-------------------------------------------------------------------
Wed Feb 19 10:45:53 UTC 2014 - zaitor@opensuse.org

- Update to version 2.11.90:
  + Add AtspitableCell, tracking the new atk interface.

-------------------------------------------------------------------
Mon Dec 16 23:08:32 UTC 2013 - dimstar@opensuse.org

- Update to version 2.11.3:
  + bgo#719508: document: add support to current page and page
    count.

-------------------------------------------------------------------
Tue Nov 19 19:58:06 UTC 2013 - dimstar@opensuse.org

- Update to version 2.11.2:
  + Add new roles and states to track atk (bgo#710464, bgo#712608,
    bgo#712609).

-------------------------------------------------------------------
Tue Sep 24 07:52:02 UTC 2013 - dimstar@opensuse.org

- Update to version 2.10.0:
  + No changes since version 2.9.92.

-------------------------------------------------------------------
Mon Sep 16 22:10:27 UTC 2013 - zaitor@opensuse.org

- Update to version 2.9.92:
  + Handle attribute lists with multiple accepted values for the
    same key when creating a collection match rule (bgo#700865).

-------------------------------------------------------------------
Tue Aug 20 07:05:45 UTC 2013 - dimstar@opensuse.org

- Update to version 2.9.90:
  + Added getStringAtOffset.

-------------------------------------------------------------------
Fri Jun 21 19:21:27 UTC 2013 - dimstar@opensuse.org

- Update to version 2.9.3:
  + Add some examples (bgo#701063).
  + Removed setting of AT_SPI_CLIENT, as it is no longer used as of
    at-spi2-core 2.9.3.

-------------------------------------------------------------------
Tue May 28 19:55:10 UTC 2013 - dimstar@opensuse.org

- Update to version 2.9.2:
  + Update for libatspi API changes (bgo#700243).

-------------------------------------------------------------------
Fri Apr 19 16:29:41 UTC 2013 - dimstar@opensuse.org

- Add support for python 3:
  + New package / spec file for python3-atspi.
  + pre_checkin.sh: syncronize python-atspi and python3-atspi.

-------------------------------------------------------------------
Tue Mar 26 07:57:02 UTC 2013 - dimstar@opensuse.org

- Update to version 2.8.0:
  + No changes since version 2.7.91.

-------------------------------------------------------------------
Mon Mar  4 23:53:17 UTC 2013 - zaitor@opensuse.org

- Update to version 2.7.91:
  + Add objectLocale property (bgo#694368).
  + Stop using a deprecated method.
  + Don't install the example, since it isn't compatible with
    Python3.
- Drop our hack in spec that removed the above mentioned example.

-------------------------------------------------------------------
Mon Feb  4 23:26:55 UTC 2013 - dimstar@opensuse.org

- Update to version 2.7.5:
  + Support new levelbar role.

-------------------------------------------------------------------
Sat Jan 12 16:51:26 UTC 2013 - dimstar@opensuse.org

- Update to version 2.7.2:
  + Add a --with-python option to configure.ac.
  + Fix getCharacterAtOffset.

-------------------------------------------------------------------
Wed Oct 24 09:40:44 UTC 2012 - dimstar@opensuse.org

- Update to version 2.7.1:
  + Export application class in the Accessibility namespace, for
    backwards compatibility.

-------------------------------------------------------------------
Tue Oct 23 19:12:12 UTC 2012 - dimstar@opensuse.org

- Do not install magFocusTracker.py sample applications. Useless
  for normal users and in plus it introduces an unversioned
  typelib(Gdk) dependency, which causes unresolvables in Factory.

-------------------------------------------------------------------
Tue Sep 25 21:27:15 UTC 2012 - dimstar@opensuse.org

- Update to version 2.6.0:
  + Install caret focus tracker into $bindir, rather than
    $pythondir/examples.
  + Fix incorrect FSF address in file headers.

-------------------------------------------------------------------
Tue Sep 18 15:34:27 UTC 2012 - zaitor@opensuse.org

- Update to version 2.5.92:
  + Fix missing argument for set_current_value method (bgo#683302).
  + Include interim focus tracker as an example.
- Add hack to set executable bit to example interim focus tracker.

-------------------------------------------------------------------
Tue Sep  4 08:54:46 UTC 2012 - dimstar@opensuse.org

- Update to version 2.5.91:
  + Fix autogen.sh for non-sourcedir build.

-------------------------------------------------------------------
Mon Aug  6 21:55:41 UTC 2012 - dimstar@opensuse.org

- Update to version 2.5.5:
  + Add getLocalizedName for actions.

-------------------------------------------------------------------
Tue Jul 17 21:14:17 UTC 2012 - dimstar@opensuse.org

- Update to version 2.5.4:
  + Wrap all interfaces (bgo#679044).

-------------------------------------------------------------------
Wed Jun 27 17:25:00 UTC 2012 - dimstar@opensuse.org

- Update to version 2.5.3:
  + Fix truth evaluation for accessibles in Python 3.
  + dict.iteritems() is no longer supported in Python 3
    (bgo#678497)
  + Re-add setTimeout (it seems that it was lost among the Python 3
    updates).
- Changes from version 2.5.2:
  + More Python 3 fixes.
  + Fix getStates regression (bgo#677070)

-------------------------------------------------------------------
Tue May  1 17:30:07 UTC 2012 - dimstar@opensuse.org

- Update to version 2.5.1:
  + Add setTimeout.
  + Some clean-ups for Python 3.

-------------------------------------------------------------------
Tue Mar 27 06:29:17 UTC 2012 - vuntz@opensuse.org

- Update to version 2.4.0:
  + No changes.

-------------------------------------------------------------------
Tue Mar 20 16:34:57 UTC 2012 - vuntz@opensuse.org

- Update to version 2.3.92:
  + Another fix for --enable-tests.

-------------------------------------------------------------------
Tue Mar  6 08:38:09 UTC 2012 - vuntz@opensuse.org

- Update to version 2.3.91:
  + Fix --enable-tests.

-------------------------------------------------------------------
Tue Feb  7 09:34:58 UTC 2012 - vuntz@opensuse.org

- Update to version 2.3.5:
  + bgo#660826: Drop unneeded pygtk check.
  + Remove exception wrapping: pyatspi will now return the real
    exception as translated by pygi, rather than LookupError.
- Remove xz BuildRequires now that it comes for free in the build
  system.

-------------------------------------------------------------------
Mon Jan 16 13:25:48 UTC 2012 - vuntz@opensuse.org

- Update to version 2.3.4:
  + bgo#666871: deregisterKeystrokeListener was broken.
- Add xz BuildRequires because we can't build a package for a
  xz-compressed tarball without explicitly specifying that... See
  bnc#697467 for more details.
- Remove checks for old non-maintained versions of openSUSE (11.1
  and earlier).

-------------------------------------------------------------------
Tue Oct 18 06:35:07 UTC 2011 - vuntz@opensuse.org

- Update to version 2.2.1:
  + Use hasattr rather than a try in registerEventListener, for
    performance.
  + bgo#661613: getOffsetAtPoint now works.

-------------------------------------------------------------------
Tue Sep 27 07:00:53 UTC 2011 - vuntz@opensuse.org

- Update to version 2.2.0:
  + No change, just a version bump.

-------------------------------------------------------------------
Fri Sep  9 16:19:18 UTC 2011 - vuntz@opensuse.org

- Update to version 2.1.91:
  + bgo#658343: Have configure check for pygobject-3.0
- Change pkgconfig(pygobject-2.0) BuildRequires to
  pkgconfig(pygobject-3.0), following upstream change.

-------------------------------------------------------------------
Wed Aug 31 13:31:10 CEST 2011 - vuntz@opensuse.org

- Update to version 2.1.90:
  + Fix getTextBeforeOffset.
  + Remove legacy pygtk dependency.
- Drop python-atspi-quotes.patch: fixed upstream.
- Add gobject-introspection BuildRequires so that we can have
  automatic typelib() Requires.
- Remove libatspi0 Requires: this is replaced by an automatic
  typelib() Requires.
- Remove python-gtk Requires: this is not needed anymore.
- Remove python-xlib Requires: the Xlib module is not used at all.
- Replace python-gobject2 Requires with python-gobject as the
  module requires the introspection-powered python-gobject.
- Remove gconf2 Recommends: it was only needed to support relocated
  pyatspi-corba, and this support is gone since 2.1.5.

-------------------------------------------------------------------
Thu Aug 18 20:57:34 UTC 2011 - dimstar@opensuse.org

- Add python-atspi-quotes.patch: Add back an accidentally dropped
  closing quote. Patch taken from git, commit 890bd7.

-------------------------------------------------------------------
Tue Aug 16 04:32:11 CEST 2011 - dimstar@opensuse.org

- Update to version 2.1.5:
  + Remove support for relocated pyatspi-corba.
  + Fix getTextBeforeOffset.

-------------------------------------------------------------------
Tue Jul 26 09:32:30 CEST 2011 - vuntz@opensuse.org

- Update to version 2.1.4:
  + Update to handle libatspi API changes.
  + bgo#653874: new ATK roles.

-------------------------------------------------------------------
Tue Jul  5 08:11:57 CEST 2011 - vuntz@opensuse.org

- Update to version 2.1.3:
  + bgo#644393: Remove document:content-changed from EVENT_TREE

-------------------------------------------------------------------
Fri Jun 17 00:44:49 CEST 2011 - vuntz@opensuse.org

- Update to version 2.1.2:
  + Merge changes from 2.0.2.
  + Add atspiVersion().
  + Fix makeSyncType to generate a proper enum (will be needed when
    enum-types branch of at-spi2-core is merged).
  + Add clearCache().
  + Cache eventTypes in events for performance reasons.
  + Add GPL2 license because a couple of test files are licensed
    under it.

-------------------------------------------------------------------
Tue May 31 11:28:09 UTC 2011 - fcrozat@suse.com

- Update to version 2.0.2:
  + Fix traceback when calling document functions.
  + Fix traceback when creating match rules with attribute sets.
  + Fix several table functions.

-------------------------------------------------------------------
Tue Apr 26 16:13:51 UTC 2011 - fcrozat@novell.com

- Update to version 2.0.1:
  + bgo#645644: Throw LookupError rather than RuntimeError.
  + Add id property.
  + Add a work-around for getStates failing on 64-bit systems with
    pygobject 2.28.3 and earlier.

-------------------------------------------------------------------
Thu Apr 21 17:21:50 CEST 2011 - vuntz@opensuse.org

- Add gconf2 Recommends as gconftool-2 is used when the module is
  loaded to know if the corba-based stack should be preferred
  instead.

-------------------------------------------------------------------
Tue Apr  5 16:42:56 UTC 2011 - fcrozat@novell.com

- Update to version 2.0.0:
  + Removed some unused files.
- Changes from version 1.91.92:
  + Added some missing __str__ functions for events and accessibles
- Changes from version 1.91.91:
  + bgo#643384: registerKeystrokeListener should pass a bit mask,
    not an enum.
- Changes from version 1.91.90:
  + Refactor EditableText so that text methods can be called from
    it.
  + Make state accessible through pyatspi.constants.
  + Fix selection interface.
  + bgo#641869: Remove --enable-relocate option.
- Changes from version 1.91.6:
  + Added source_name and source_role to events.
  + Call gconftool-2 to check the value of
    /desktop/gnome/interface/at-spi-corba rather than importing
    gconf, since the latter can cause problems if new and old
    versions of the Python bindings are mixed.
  + Added setExtents, setSize, and setPosition for components.
  + Added setCacheMask.
- Changes from version 1.91.5:
  + Fixed generateKeyboardEvent, description, and allModifiers.
  + Added a dummy stateset.unref function for backwards
    compatibility.
  + Added a pumpQueuedEvents stub.
  + Added RELATION_EMBEDDED_BY.
  + Hide children attribute since it is currently broken and caused
    a crash with Accerciser..
  + Wrap event type so that sub-fields can be accessed.
- Changes from version 1.91.4:
  + Added a dummy freeMatchRule function.
  + Attribute fixes.
  + __getitem__ now supports negative indices.
  + Fixed some properties, relationToString, listInterfaces,
    various text methods.
  + Raise notImplementedError when querying unimplemented
    interfaces.
- Changes from version 1.91.3:
  + This is a major refactor using the C-based libatspi as a core.
    This should significantly improve performance.  However, this
    release is very buggy and is more of a development snapshot
    than a usable release.
- Changes from version 1.91.1:
  + Add configure check for python-xlib
  + Have calls on the async bus time out after 2 seconds
  + Added a LRU cache for objects that use the soft cache
- Changes from version 1.91.0:
  + --disable-relocate is the default again.
  + Added a "soft cache" to try to avoid repeatedly querying for
    information in cases where we never received an
    AccessibleAdded signal for an object.
- Requires libatspi0, needed for introspection to work correctly.
- Remove the IS_DEFAULT_SPI_STACK handling, this is the default
  stack and it is no longer configurable.
- Replace BuildRequires on python with pkgconfig(pygobject-2.0).

-------------------------------------------------------------------
Thu Nov 18 10:22:26 CET 2010 - vuntz@opensuse.org

- Update to version 0.4.1:
  + Add configure check for python-xlib.

-------------------------------------------------------------------
Tue Sep 28 01:53:42 CEST 2010 - vuntz@opensuse.org

- Update to version 0.4.0:
  + Version bump to stable 0.4.0, without any change.

-------------------------------------------------------------------
Tue Aug 31 08:57:11 CEST 2010 - vuntz@opensuse.org

- Update to version 0.3.91:
  + Enable relocate by default for now.
  + Ensure that queued events are delivered when calling
    registry.stop().
  + If an unexpected exception is thrown when checking for the
    accessibility bus (ie, python-xlib is missing), throw the
    exception rather than silently reverting to the session bus.

-------------------------------------------------------------------
Tue Aug 24 17:25:40 CEST 2010 - vuntz@opensuse.org

- Add python-xlib Requires. Thanks to Mike Gorse for noticing this.

-------------------------------------------------------------------
Tue Aug 17 11:12:32 CEST 2010 - dimstar@opensuse.org

- Update to version 0.3.90:
  + Have registerEventListener an deregisterEventListener notify
    the registry, as is now needed.
  + Avoid raising an event multiple times if EVENT_TREE is used to
    register for all events.

-------------------------------------------------------------------
Fri Aug  6 13:51:48 CEST 2010 - vuntz@opensuse.org

- Update to version 0.3.6:
  + Some thread safety fixes; should no longer deadlock when
    listening for events using Strongwind.
- Changes from version 0.3.4:
  + Listen for AddAccessible and RemoveAccessible at the
  DesktopCache level. This fixes a regression with Firefox for
  instance that was introduced in v0.3.3.

-------------------------------------------------------------------
Fri Jun  4 20:55:17 UTC 2010 - sshaw@decriptor.com

- Update to version 0.3.3:
  + Hyperlink fixes.
  + When an object's parent is set to null, remove it from the
    parent in the cache.
  + Fix an issue where a state-changed handler can be called before
    the cache received the signal and updated the state.
  + Only range check for __getitem__, not getChildAtIndex. This is
    pyatspi-corba's behavior and should improve performance in some
    cases.
  + Fix tracebacks when checking some event properties.
  + Fix a traceback when simulating a defunct state for an object
    that has gone away.
  + Fix traceback when calling queryDocument.getAttributes(),
    queryText().getCharacterExtents(), and
    queryValue().setCurrentValue().
  + Fix handling of some ChildrenChanged signals sent by Firefox.
- Update to version 0.3.2:
  + Remove double deletion of application from the desktop cache
    handler. Was causing a mostly harmless exception when an
    application shut down.
  + Role changes now update the cache.
  + Avoid throwing an exception in getState() if an object no
    longer exists. This avoids potentially throwing an eception
    where at-spi-corba may not.
  + Do not use the cache if registry.start() has not been called;
    allows simple scripts without a main loop to work better.
- Update to version 0.3.1.1:
  + Install to $PYTHONDIR again, since we have no arch-specific
    dependencies.
  + Do not dispatch events while waiting for a reply from a method
    call.
- Update to version 0.3.1:
  + Fixed GetLink, GetColumnHeader, getAccessibleAtPoint, and
    possibly others.
  + Fix children-changed, property-change::accessible-parent, and
    active-descendant-changed events.
  + Update an accessible's StateSet when a StateChanged signal is
    received.
  + Properly fetch children of MANAGES_DESCENDANTS objects (ie, do
    not use cache)
  + The desktop's role is now set to ROLE_DESKTOP_FRAME.
  + Use pyexecdir as a base rather than pythondir.
  + Disable relocation by default.
- This fixes a crash in firefox when at-spi2 is used, see
  bnc#611149.

-------------------------------------------------------------------
Thu Apr  8 01:41:45 CEST 2010 - vuntz@opensuse.org

- Make this new at-spi stack optional again: the at-spi2 developers
  think it's safer to ship 11.3 with the old stack by default.
- Add a IS_DEFAULT_ATSPI_STACK define to easily change this
  behavior.

-------------------------------------------------------------------
Wed Mar 31 01:27:30 CEST 2010 - vuntz@opensuse.org

- Update to version 0.1.8:
  + Support id property
  + Set AT_SPI_CLIENT for use by at-spi2-atk
  + Set ROLE_UNKNOWN for desktop for compatibility with CORBA
    at-spi

-------------------------------------------------------------------
Sun Feb 21 17:22:08 CET 2010 - vuntz@opensuse.org

- Update to version 0.1.7:
  + Change the interface name from org.freedesktop to org.a11y.
  + Add fix for name error that was causing unit tests to fail.

-------------------------------------------------------------------
Fri Feb 12 15:05:03 CET 2010 - vuntz@opensuse.org

- Update to version 0.1.6:
  + Make AT-SPI/CORBA the default and relocate AT-SPI/D-Bus
  + Move the application argument to the end of the event structure
  + Enable Re-entrancy within pyatspi.
  + Changes to properly update the cache and fix orca performance
    issues
  + Re-factor cache to use a single dictionary.
  + Fix property getting to use the correct interfaces.
  + Modify pyatspi to use the accessible object located on the
    registryd.
  + Fix an event bug
  + bgo#607077 - pyatspi2: magic to detect whether to use corba
    version or not can be broken
- Drop python-atspi-fix-no-gconf.patch: fixed upstream.
- Pass --disable-relocate to configure because we want at-spi2 by
  default.

-------------------------------------------------------------------
Fri Jan 15 15:40:48 CET 2010 - vuntz@opensuse.org

- Add python-atspi-fix-no-gconf.patch to make python-atspi work if
  the gconf bindings are not available.

-------------------------------------------------------------------
Tue Jan 12 11:58:59 CET 2010 - vuntz@opensuse.org

- Update to version 0.1.5:
  + For a full list of changes, see
    http://git.gnome.org/browse/pyatspi2/log/?id=PYATSPI_0_1_5
  + Move the allModifiers function in to deviceevent.py to resolve
    missing symbol error when registering keystrokes for all
    modifiers.
  + Use pyatspi_corba if /desktop/gnome/interface/at-spi-corba is
    True
  + Additional work on bgo#606251 - Handle CORBA vs. D-Bus choice
    better
  + Modifications to use the new leasing scheme.
  + Add application reference to the event structure.
  + Make the cache update on property or child-changed signals.
  + Add children-changed event emission for top-level accessibles.
  + Temporarily switch off re-entrancy.

-------------------------------------------------------------------
Tue Dec 22 17:42:01 CET 2009 - vuntz@opensuse.org

- Update to version 0.1.4:
  + For a full list of changes, see
    http://git.gnome.org/browse/pyatspi2/log/?id=PYATSPI_0_1_4
  + Fix 100% CPU usage. The event dispatcher funtion was running
    continuously.
  + Addition of new 'Accessibility' D-Bus bus. The bus address is
    located using X properties.
  + Do not rely on cache for children of MANAGES_DESCENDANTS
    objects
  + Fixes to the Test desktop allowing the unit tests to be run in
    non-cached mode.
  + Fix the getAttributes method of the text api to return
    semicolon delimited string as required by accerciser.
  + Fix problem with children changed signal when adding or
    removing applications.
  + Change name of exception to new merged
    AccessibleObjectNoLongerAvailable exception.
  + Correct wrong method name in the 'Selection' interface.
  + Remove reference to 'interfaces' module that was causing error
    in orca test suite.
  + Modify selection interface to use the new out-of-process
    protocol for transferring accessible objects.
  + Added collection support
  + Perform type checking on Enumeration equality.
  + Fix inconsistencies in Table interface introduced by
    out-of-process and method name changes in the protocol.
  + Fix get_application errors. A check was not made to see if the
    application name was the Registry.
  + Fix name errors in table.py - use of 'interfaces' module.
  + Up the recursion limit. The '15' limit was met while running
    the orca test suite.
  + Fix name error in create_application method of the
    CachedDesktop.
  + Add a missing 'unref' function to the StateSet api. This
    function does nothing and is needed for compatibility with the
    CORBA class.

-------------------------------------------------------------------
Wed Dec  2 18:47:05 CET 2009 - vuntz@opensuse.org

- Initial package, based on a previous version of at-spi2-atk.
- Provide a pyatspi virtual package (that python-atspi-corba also
  provides).