File ffmpeg-libcdio_cdda-pkgconfig.patch of Package ffmpeg-4.openSUSE_Leap_42.3_Update

---
 configure |    2 ++
 1 file changed, 2 insertions(+)

Index: ffmpeg-4.0.1/configure
===================================================================
--- ffmpeg-4.0.1.orig/configure	2018-06-16 03:12:16.000000000 +0200
+++ ffmpeg-4.0.1/configure	2018-06-30 00:17:17.733924139 +0200
@@ -6243,6 +6243,8 @@ enabled libjack &&
 enabled sndio && check_lib sndio sndio.h sio_open -lsndio
 
 if enabled libcdio; then
+    # cdio_cdda needs -lrt, get it from pkg-config from the external pkg
+    #l=$(pkg-config --libs libcdio_paranoia libcdio_cdda libcdio)
     check_pkg_config libcdio libcdio_paranoia "cdio/cdda.h cdio/paranoia.h" cdio_cddap_open ||
     check_pkg_config libcdio libcdio_paranoia "cdio/paranoia/cdda.h cdio/paranoia/paranoia.h" cdio_cddap_open ||
     check_lib libcdio "cdio/cdda.h cdio/paranoia.h" cdio_cddap_open -lcdio_paranoia -lcdio_cdda -lcdio ||
openSUSE Build Service is sponsored by