File libquvi.changes of Package libquvi

-------------------------------------------------------------------
Sat Jul 18 02:45:31 UTC 2015 - i@marguerite.su

- add patch: libquvi-0.9.4-lua-5.2.patch
  * compatibility w/ lua 5.2+
  * luaL_register replaced by luaL_newlib 

-------------------------------------------------------------------
Tue Mar 10 13:00:17 CET 2015 - sbrabec@suse.cz

- Move shared library to libquvi%{soname} to conform to Shared
  Library Packaging Policy and allow parallel installation of more
  versions even without multiversion.
- Use last change date instead of build date.
  libquvi-fake-build-date.patch -> libquvi-stable-build-date.patch
- Add libquvi.rpmlintrc to spec file and update skipped checks.

-------------------------------------------------------------------
Tue Mar 10 10:30:51 UTC 2015 - pgajdos@suse.com

- no build date [bnc#916338]
  + libquvi-fake-build-date.patch

-------------------------------------------------------------------
Mon Feb 10 19:32:50 UTC 2014 - dimstar@opensuse.org

- Update to version 0.9.4:
  + API: Return URLs in escaped (percent-encoded) form.
  + m_url_unescaped_form: Check if g_uri_unescape_string fails.

-------------------------------------------------------------------
Mon Oct 21 13:48:36 UTC 2013 - tchvatal@suse.com

- Version bump to 0.9.3:
  - AC_PREREQ: Bump to 2.69 [c591b1b]
  - API: Add QUVI_OPTION_ALLOW_COOKIES [f56798b]
  - API: Add QUVI_VERSION_SCRIPTS_CONFIGURATION [f0c95e0]
  - API: quvi_version: Read "version" file as ini-file [4466c98]
  - FIX: error: implicit declaration of function 'luaL_register' [f02cc3a]
  - FIX: Unescape input URL before URL resolving [f2ce9b7]
  - quvi.http.cookie: Return unless QUVI_OPTION_ALLOW_COOKIES is QUVI_TRUE [876949e]

-------------------------------------------------------------------
Wed Aug 14 09:08:35 UTC 2013 - dimstar@opensuse.org

- Update to version 0.9.2:
  + One year of bugfixing and improvements. Please see NEWS for
    a full list of changes.
- Add -DLUA_COMPAT_MODULE to CFLAGS, allowing to use compatibility
  features of LUA 5.1, using LUA 5.2.
- Move the library to libquvi. NOTE: the current library is a .so
  file only and does not have version information. This is an
  intentional behavior from upstream and accepted during the 0.9
  release cycle. The versions are ABI incompatible to each other.
  See http://repo.or.cz/w/libquvi.git/commit/20b1e for a rationale.
- Add libquvi-rpmlintrc: we need to filter out the library being
  in the main package now. rpmlintrc does not know correcly about
  this case, and considering that this is a temporary situation
  during the 0.9 cycle, it's also not worthy to address this in
  rpmlintrc code.

-------------------------------------------------------------------
Sat Dec 29 18:01:49 UTC 2012 - p.drouand@gmail.com

- Update to 0.4.1 version:
  * Add examples/parse.c [a26f5f6]
  * Add examples/supported.c [179d997]
  * DOC: Replace buzzhumor with gaskrank [3d2e015]
  * FIX: Lua 5.2: Use luaL_newstate instead (#89) [6de7322]
  * FIX: Make verify c/b check against correct option [0c4ff3b]
  * FIX: Use dirname(3) properly [b2f1621]
- Remove conditionnal BuildRequires macros; now work fine with lua 5.2

-------------------------------------------------------------------
Mon Jan 23 09:26:42 UTC 2012 - vuntz@opensuse.org

- Revert my previous change: libquvi doesn't work with lua 5.2, see
  http://sourceforge.net/apps/trac/quvi/ticket/89

-------------------------------------------------------------------
Tue Jan 17 12:37:03 UTC 2012 - vuntz@opensuse.org

- Always build against lua-devel: lua 5.2 on 12.2/Factory doesn't
  seem to be an issue.

-------------------------------------------------------------------
Tue Jan 10 13:13:14 UTC 2012 - vuntz@opensuse.org

- New package (version 0.4.0).
- This is based on the quvi 0.2.19 package: quvi got split in three
  modules upstream for 0.4.x.
openSUSE Build Service is sponsored by