File libcroco-CVE-2017-8834.patch of Package libcroco.11164

From deda38539f5b25616aa294d8b19d33ebf8e175ff Mon Sep 17 00:00:00 2001
From: Mike Gorse <mgorse@alum.wpi.edu>
Date: Thu, 2 May 2019 10:54:43 -0500
Subject: [PATCH] cr_utils_read_char_from_utf8_buf: move past invalid UTF-8

Otherwise, the offending character is never consumed, possibly leading
to an infinite loop.

https://bugzilla.gnome.org/show_bug.cgi?id=782647
---
 src/cr-utils.c | 1 +
 1 file changed, 1 insertion(+)

diff --git a/src/cr-utils.c b/src/cr-utils.c
index 2420cec..6cf4849 100644
--- a/src/cr-utils.c
+++ b/src/cr-utils.c
@@ -505,6 +505,7 @@ cr_utils_read_char_from_utf8_buf (const guchar * a_in,
 
         } else {
                 /*BAD ENCODING */
+                nb_bytes_2_decode = 1;
                 goto end;
         }
 
-- 
2.20.1
openSUSE Build Service is sponsored by