File 0001-Extend-the-MariaDB-define-check-to-cover-the-later-v.patch of Package libqt5-qtbase.16540

From b2bd1eef198b9d4774e1f10c77d6622813938543 Mon Sep 17 00:00:00 2001
From: Andy Shaw <andy.shaw@qt.io>
Date: Wed, 27 Sep 2017 09:23:10 +0200
Subject: [PATCH] Extend the MariaDB define check to cover the later versions
 too

Change-Id: Ide89b4e07feb116bf152cbf3f5630d313e8ba0f1
---
 src/plugins/sqldrivers/mysql/qsql_mysql.cpp | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/plugins/sqldrivers/mysql/qsql_mysql.cpp b/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
index d9aebff700..7694698bff 100644
--- a/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
+++ b/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
@@ -1160,14 +1160,14 @@ static void qLibraryInit()
 # endif // MYSQL_VERSION_ID
 #endif // Q_NO_MYSQL_EMBEDDED
 
-#ifdef MARIADB_BASE_VERSION
+#if defined(MARIADB_BASE_VERSION) || defined(MARIADB_VERSION_ID)
     qAddPostRoutine(mysql_server_end);
 #endif
 }
 
 static void qLibraryEnd()
 {
-#if !defined(MARIADB_BASE_VERSION)
+#if !defined(MARIADB_BASE_VERSION) && !defined(MARIADB_VERSION_ID)
 # if !defined(Q_NO_MYSQL_EMBEDDED)
 #  if MYSQL_VERSION_ID > 40000
 #   if (MYSQL_VERSION_ID >= 40110 && MYSQL_VERSION_ID < 50000) || MYSQL_VERSION_ID >= 50003
-- 
2.16.1
openSUSE Build Service is sponsored by