LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File ack.spec of Package ack (Project utilities)

# vim: set ts=4 sw=4 et:
#
# spec file for package ack
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{!?perl_make_install:  %global perl_make_install make DESTDIR=$RPM_BUILD_ROOT install_vendor}

%if 0%{?suse_version} >= 1100 || 0%{?fedora} >= 13
%define with_pod 1
%else
%define with_pod 0
%endif

Name:           ack
Version:        2.10
Release:        0
Summary:        Grep-Like Text Finder
License:        Artistic-2.0
Group:          Productivity/Text/Utilities
Source:         http://cpan.metacpan.org/authors/id/P/PE/PETDANCE/ack-%{version}.tar.gz
Patch1:         ack-ignore-osc.patch
Patch2:         ack-fix_smartcase_test_for_old_perl.patch
Patch3:         ack-add_spec.patch
Url:            http://beyondgrep.com/
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Requires:       perl
BuildRequires:  make
BuildRequires:  perl >= 5.8.8
BuildRequires:  perl(File::Next) >= 1.10
BuildRequires:  perl(IO::Pty)
%if %with_pod
BuildRequires:  perl(Test::Pod) >= 1.14
%endif
BuildArch:      noarch
Requires:       perl-App-Ack = %{version}-%{release}
Requires:       perl-base = %{perl_version}

%description
ack is a grep-like tool tailored to working with large trees of source code.

%package -n perl-App-Ack
Summary:        Grep-Like Text Finder Perl Module
Group:          Development/Libraries/Perl
Requires:       perl-base = %{perl_version}
Requires:       perl(File::Next) >= 1.10

%description -n perl-App-Ack
App::Ack is a grep-like tool tailored to working with large trees of source
code.

%prep
%setup -q -n "ack-%{version}"
%patch1 -p1
%if 0%{?suse_version} > 0 && 0%{?suse_version} < 1000 || 0%{?rhel_version} > 0 && 0%{?rhel_version} < 500
%patch2
%endif
%patch3 -p1

%build
perl Makefile.PL
make %{?_smp_mflags}

%install
%perl_make_install

%if 0%{?perl_process_packlist:1}
%perl_process_packlist
%else
rm "%{buildroot}%{perl_archlib}/perllocal.pod"
%endif

# remove .packlist file
rm -rf "%{buildroot}%{perl_vendorarch}/auto/ack"

rm -f "%{buildroot}/var/adm/perl-modules/ack"

install -d rpmdoc_ack
for f in Changes README.md LICENSE.md; do
    ln -s ../ack/"$f" rpmdoc_ack/"$f"
done

%check
make test

%files
%defattr(-,root,root)
%doc rpmdoc_ack/*
%{_bindir}/ack
%doc %{_mandir}/man1/ack.1%{ext_man}

%files -n perl-App-Ack
%defattr(-,root,root)
%doc Changes README.md LICENSE.md
%dir %{perl_vendorlib}/App
%{perl_vendorlib}/App/Ack.pm
%{perl_vendorlib}/App/Ack
%if 0%{?perl_process_packlist:1}
%endif

%changelog