LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File dhcp.README.upgrade of Package dhcp.219 (Project openSUSE:12.1:Update)

When upgrading from version 2 to version 3, there are three things that are
helpful to know:


 - you must use the ddns-update-style keyword. Either set it to "none", e.g.
   like this:

      ddns-update-style none; ddns-updates off;

   If you don't have a statement about ddns at all, dhcpd-3 will not start, 
   and give you a message about "ddns-update-style ad-hoc;". (Don't use that 
   one -- the ad-hoc style is depracated. Use the interim style instead.)

   If you used DDNS with 3.0beta1 versions and want to upgrade, you can
   convert the lease file with this script:
   /usr/share/doc/packages/dhcp/3.0b1-lease-convert
   

 - in version 3, if you define an IP address range for dynamic allocation, it
   will not work for bootp by default. Contrary to version 2 you have to
   explicitely allow bootp like this:

      range dynamic-bootp 192.168.0.10 192.168.0.20;


 - version 3 will not act as an "authoritative" server by default. That means
   that it will not send DHCPNAKs for addresses that can't be requested. If you
   run the principal DHCP server of your network, add the 

      authoritative;

   statement to the subnet declaration. 


Apart from that, you should be able to use the same configuration as before!
Please send comments to poeml@suse.de.