LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File fillmore-lombard.spec of Package fillmore-lombard (Project openSUSE:11.4)

#
# spec file for package fillmore-lombard
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           fillmore-lombard
Version:        0.1.0
Release:        4
# FIXME: on update, check if http://trac.yorba.org/ticket/2388 is solved, and update %install accordingly
License:        LGPLv2.1+
Summary:        Audio and Video Editors for GNOME
Url:            http://yorba.org/
Group:          Productivity/Multimedia/Other
Source:         %{name}-%{version}.tar.bz2
# PATCH-FIX-UPSTREAM changeset_r1838.diff vuntz@opensuse.org -- Taken from svn, update for vala changes
Patch0:         changeset_r1838.diff
# PATCH-FIX-UPSTREAM changeset_r1946.diff vuntz@opensuse.org -- Taken from svn, fix issue in .desktop files
Patch1:         changeset_r1946.diff
# PATCH-FIX-UPSTREAM changeset_r1947.diff vuntz@opensuse.org -- Taken from svn fix --prefix in configure
Patch2:         changeset_r1947.diff
# PATCH-FIX-UPSTREAM changeset_r1953.diff vuntz@opensuse.org -- Taken from svn, another update for vala changes
Patch3:         changeset_r1953.diff
# PATCH-FIX-UPSTREAM fillmore-lombard-no-update-mimedb.patch vuntz@opensuse.org -- Do not call update-mime-database on install. Sent upstream by mail (2010-12-09)
Patch4:         fillmore-lombard-no-update-mimedb.patch
BuildRequires:  vala
BuildRequires:  update-desktop-files
BuildRequires:  pkgconfig(gdk-x11-2.0)
BuildRequires:  pkgconfig(gee-1.0)
BuildRequires:  pkgconfig(gstreamer-0.10)
BuildRequires:  pkgconfig(gstreamer-base-0.10)
BuildRequires:  pkgconfig(gstreamer-controller-0.10)
BuildRequires:  pkgconfig(gstreamer-interfaces-0.10)
BuildRequires:  pkgconfig(gstreamer-pbutils-0.10)
BuildRequires:  pkgconfig(gtk+-2.0)
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
This is a meta package / source for fillmore and lombard together.

Fillmore is an audio editor designed for the GNOME desktop environment.
It allows you to record audio, place audio on multiple tracks, adjust
the position of the track in the stereo track and export your project
as a single stereo file.

Lombard is a video editor designed for the GNOME desktop environment.
It allows you to manipulate multiple video and audio clips and export
your project as a single video file.

%package -n fillmore
License:        LGPLv2.1+
Summary:        Audio Editor for GNOME
Group:          Productivity/Multimedia/Sound/Editors and Convertors
Requires:       gstreamer-0_10-plugin-gnonlin

%description -n fillmore
Fillmore is an audio editor designed for the GNOME desktop environment.
It allows you to record audio, place audio on multiple tracks, adjust
the position of the track in the stereo track and export your project
as a single stereo file.

%package -n lombard
License:        LGPLv2.1+
Summary:        Video Editor for GNOME
Group:          Productivity/Multimedia/Video/Editors and Convertors
Requires:       gstreamer-0_10-plugin-gnonlin

%description -n lombard
Lombard is a video editor designed for the GNOME desktop environment.
It allows you to manipulate multiple video and audio clips and export
your project as a single video file.

%prep
%setup -q -n media-%{version}
%patch0 -p3
%patch1 -p3
%patch2 -p3
%patch3 -p3
%patch4 -p1

%build
# We can't use the configure macro: it's not a standard autotools configure script
export CFLAGS="%{optflags} -fPIC"
./configure \
        --prefix=%{_prefix}
%__make %{?_smp_mflags}

%install
%makeinstall DISABLE_ICON_UPDATE=1 DISABLE_MIME_UPDATE=1
%suse_update_desktop_file fillmore AudioVideoEditing
%suse_update_desktop_file lombard AudioVideoEditing
# We should call fdupes for duplicate files in %{_datadir}, except
# that we have two subpackages with files there, so we can't do
# that blindly :/

%clean
rm -rf %{buildroot}

%post -n fillmore
%if 0%{?suse_version} > 1130
%desktop_database_post
%icon_theme_cache_post
%mime_database_post
%else
if test -x usr/bin/update-mime-database ; then
  usr/bin/update-mime-database usr/share/mime >/dev/null
fi
%endif

%postun -n fillmore
%if 0%{?suse_version} > 1130
%desktop_database_postun
%icon_theme_cache_postun
%mime_database_postun
%else
if test -x usr/bin/update-mime-database ; then
  usr/bin/update-mime-database usr/share/mime >/dev/null
fi
%endif

%post -n lombard
%if 0%{?suse_version} > 1130
%desktop_database_post
%icon_theme_cache_post
%mime_database_post
%else
if test -x usr/bin/update-mime-database ; then
  usr/bin/update-mime-database usr/share/mime >/dev/null
fi
%endif

%postun -n lombard
%if 0%{?suse_version} > 1130
%desktop_database_postun
%icon_theme_cache_postun
%mime_database_postun
%else
if test -x usr/bin/update-mime-database ; then
  usr/bin/update-mime-database usr/share/mime >/dev/null
fi
%endif

%files -n fillmore
%defattr(-,root,root)
%doc AUTHORS COPYING MAINTAINERS NEWS README THANKS
%{_bindir}/fillmore
%{_datadir}/applications/fillmore.desktop
%{_datadir}/fillmore/
%{_datadir}/icons/hicolor/scalable/apps/fillmore.svg
%{_datadir}/mime/packages/fillmore.xml

%files -n lombard
%defattr(-,root,root)
%doc AUTHORS COPYING MAINTAINERS NEWS README THANKS
%{_bindir}/lombard
%{_datadir}/applications/lombard.desktop
%{_datadir}/lombard/
%{_datadir}/icons/hicolor/scalable/apps/lombard.svg
%{_datadir}/mime/packages/lombard.xml

%changelog