LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File gobby04.spec of Package gobby04 (Project openSUSE:Factory)

# spec file for package gobby04
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/

Name:           gobby04
%define _name   gobby
BuildRequires:  fdupes
BuildRequires:  gcc-c++
# For directory ownership:
BuildRequires:  gnome-themes
BuildRequires:  intltool
BuildRequires:  update-desktop-files
BuildRequires:  pkgconfig(avahi-glib)
BuildRequires:  pkgconfig(gnome-vfs-2.0)
BuildRequires:  pkgconfig(gtkmm-2.4)
BuildRequires:  pkgconfig(gtksourceview-2.0)
BuildRequires:  pkgconfig(gtkspell-2.0)
BuildRequires:  pkgconfig(libxml++-2.6)
BuildRequires:  pkgconfig(net6-1.3)
BuildRequires:  pkgconfig(obby-0.4)
Version:        0.4.13
Release:        0
Summary:        Gobby collaborative editor (old protocol)
License:        GPL-2.0 ; GPL-2.0+
Group:          System/GUI/GNOME
Source:         http://releases.0x539.de/gobby/%{_name}-%{version}.tar.gz
# PATCH-FIX-OPENSUSE gobby04-desktop.patch vuntz@novell.com -- Remove icon extension, and make it call gobby-0.4 (to have it parallel-installable with 0.5)
Patch0:         gobby04-desktop.patch
Url:            http://gobby.0x539.de/
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Requires:       obby >= 0.4.6
Requires(post): update-alternatives
Requires(postun): update-alternatives
# The build service fails to build the package because it doesn't really
# understand Requires(post), so use PreReq too (see bnc#439232).
%if %defined suse_version
PreReq:         update-alternatives
Recommends:     %{name}-lang

Gobby is a free collaborative editor. This means that it provides you
with the possibility to edit files simultaneously with other users over
a network. It supports multiple documents in one session and a
multi-user chat. The platforms on which you could use Gobby are so far
Microsoft Windows, Linux, Mac OS X and other Unix-like ones.

This is the 0.4 version of Gobby, which is not using the Infinote

%setup -q -n %{_name}-%{version}

%configure \
    --with-gnome \
%{__make} %{?jobs:-j%jobs}

# Rename some files for better parallel installability with 0.5 version
mv %{buildroot}%{_bindir}/%{_name} %{buildroot}%{_bindir}/%{_name}-0.4
mv %{buildroot}%{_datadir}/applications/%{_name}.desktop %{buildroot}%{_datadir}/applications/%{_name}-0.4.desktop
mv %{buildroot}%{_mandir}/man1/%{_name}.1 %{buildroot}%{_mandir}/man1/%{_name}-0.4.1
# done renaming files
%find_lang %{_name} %{?no_lang_C}
%suse_update_desktop_file -N "Gobby 0.4" -G "Collaborative Editor" %{_name}-0.4 X-SuSE-Core-Internet
%fdupes %{buildroot}

%{__rm} -rf %{buildroot}

# If the %{name} group is in automatic mode, then this will also switch all
# symlinks automatically
update-alternatives --install %{_bindir}/%{_name} %{_name} %{_bindir}/%{_name}-0.4 10 --slave %{_mandir}/man1/%{_name}.1.gz %{_name}.1.gz %{_mandir}/man1/%{_name}-0.4.1.gz
%if 0%{?suse_version} > 1130
%icon_theme_cache_post HighContrastLargePrint
%icon_theme_cache_post HighContrastLargePrintInverse

# Note: we don't use "$1 -eq 0", to avoid issues if the package gets renamed
if [ ! -f %{_bindir}/%{_name}-0.4 ]; then
  update-alternatives --remove %{_name} %{_bindir}/%{_name}-0.4
%if 0%{?suse_version} > 1130
%icon_theme_cache_postun HighContrastLargePrint
%icon_theme_cache_postun HighContrastLargePrintInverse

# Workaround old bug in 11.1/11.2 packages that always removed the symlinks in
# %postun. Can be removed during 12.2 development.
if [ ! -f %{_bindir}/%{_name} -a -f %{_bindir}/%{_name}-0.4 ]; then
  update-alternatives --install %{_bindir}/%{_name} %{_name} %{_bindir}/%{_name}-0.4 10 --slave %{_mandir}/man1/%{_name}.1.gz %{_name}.1.gz %{_mandir}/man1/%{_name}-0.4.1.gz

%defattr (-, root, root)
%doc %{_mandir}/man1/*.*
# FIXME: gnome-themes does not provide %{_datadir}/icons/HighContrastLargePrint*/scalable yet.
%exclude %{_datadir}/icons/HighContrastLargePrint/scalable/*
%exclude %{_datadir}/icons/HighContrastLargePrintInverse/scalable/*
# Not versioned, but there's no conflict with gobby 0.5 here

%files lang -f %{_name}.lang