LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File kate.spec of Package kate (Project KDE:Distro:Factory)

#
# spec file for package kate
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           kate
Version:        4.9.3
Release:        0
Summary:        Advanced Text Editor
License:        GPL-2.0+
Group:          Productivity/Editors/Other
Url:            http://www.kde.org/
Source0:        %{name}-%{version}.tar.xz
BuildRequires:  fdupes
BuildRequires:  libkde4-devel >= %version
BuildRequires:  xz
Requires:       libktexteditor = %{version}
Provides:       kde4-kate = 4.3.0
Obsoletes:      kde4-kate < 4.3.0
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%kde4_runtime_requires

%description
Kate is an advanced text editor for KDE.
  
%prep
%setup -q

%build
%ifarch ppc64
RPM_OPT_FLAGS="%{optflags} -mminimal-toc"
%endif
  %cmake_kde4 -d build
  %make_jobs

%install
  cd build
  %make_install
  %suse_update_desktop_file kate                 TextEditor
  %suse_update_desktop_file ktesnippets_editor   TextEditor
  %suse_update_desktop_file kwrite               TextEditor
  %fdupes -s %{buildroot}
  %kde_post_install

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%clean
  rm -rf %{buildroot}
  rm -rf filelists

%package devel
Summary:        Advanced Text Editor Development Headers
Group:          Development/Libraries/KDE
Requires:       kate = %{version}
Requires:       libkde4-devel
Provides:       kde4-kate-devel = 4.3.0
Obsoletes:      kde4-kate-devel < 4.3.0

%description devel
Files needed for development of Kate plugins.
 
%files devel
%defattr(-,root,root)
%{_kde4_includedir}/kate/
%{_kde4_includedir}/kate_export.h
%{_kde4_includedir}/ktexteditor_codesnippets_core/
%{_kde4_libdir}/libkateinterfaces.so
%{_kde4_libdir}/libkatepartinterfaces.so
%{_kde4_libdir}/libktexteditor_*.so

%package -n libktexteditor
Summary:        Advanced Text Editor library
Group:          Productivity/Editors/Other

%description -n libktexteditor
The libraries shared by kwrite and kate editors.
 
%post -n libktexteditor -p /sbin/ldconfig

%postun -n libktexteditor -p /sbin/ldconfig

%files -n libktexteditor
%defattr(-,root,root)
%config %{_kde4_configdir}/katepartpluginsrc
%config %{_kde4_configdir}/ktexteditor_codesnippets_core.knsrc
%{_kde4_appsdir}/katepart/
%{_kde4_appsdir}/ktexteditor_exporter/
%{_kde4_appsdir}/ktexteditor_iconinserter/
%{_kde4_appsdir}/ktexteditor_insanehtml_le/
%{_kde4_appsdir}/ktexteditor_insertfile/
%{_kde4_appsdir}/ktexteditor_kdatatool/
%{_kde4_appsdir}/ktexteditor_snippets/
%{_kde4_iconsdir}/hicolor/*/apps/ktexteditorautobrace.svgz
%{_kde4_iconsdir}/oxygen/*/actions/*.png
%{_kde4_libdir}/libkatepartinterfaces.so.*
%{_kde4_libdir}/libktexteditor_*.so.*
%{_kde4_modulesdir}/katepart.so
%{_kde4_modulesdir}/ktexteditor_*.so
%{_kde4_servicesdir}/ktexteditor_*.desktop

%files
%defattr(-,root,root)
%config %{_kde4_configdir}/katefiletemplates.knsrc
%config %{_kde4_configdir}/katemoderc
%config %{_kde4_configdir}/katerc

%exclude %{_kde4_modulesdir}/katepart.so

%{_datadir}/mime/packages/ktesnippets.xml
%{_kde4_applicationsdir}/kate.desktop
%{_kde4_applicationsdir}/ktesnippets_editor.desktop
%{_kde4_appsdir}/kate/
%{_kde4_appsdir}/katexmltools/
%{_kde4_appsdir}/kconf_update/kate-2.4.upd
%{_kde4_bindir}/kate
%{_kde4_bindir}/ktesnippets_editor
%{_kde4_htmldir}/en/kate/
%{_kde4_iconsdir}/hicolor/*/apps/kate.*
%{_kde4_libdir}/libkateinterfaces.so.*
%{_kde4_libdir}/libkdeinit4_kate.so
%{_kde4_mandir}/man?/*
%{_kde4_modulesdir}/kate*.so
%{_kde4_modulesdir}/plasma_applet_katesession.so
%{_kde4_servicesdir}/kate*.desktop
%{_kde4_servicesdir}/plasma-applet-katesession.desktop
%{_kde4_servicetypesdir}/kateplugin.desktop

%package -n kwrite
Summary:        KDE Text Editor
Group:          Productivity/Editors/Other
Requires:       libktexteditor = %{version}
Provides:       kde4-kwrite = 4.3.0
Provides:       kdebase3:/opt/kde3/bin/kwrite
Obsoletes:      kde4-kwrite < 4.3.0
%kde4_runtime_requires

%description -n kwrite
KWrite is the default text editor of the K desktop environment.
 
%package -n kwrite-doc
Summary:        KDE Text Editor: Documentation
Group:          Productivity/Editors/Other
Requires:       kwrite = %{version}

%description -n kwrite-doc
KWrite is the default text editor of the K desktop environment.

This package contains the documentation for KWrite
 
%post -n kwrite -p /sbin/ldconfig

%postun -n kwrite -p /sbin/ldconfig

%files -n kwrite
%defattr(-,root,root)
%{_kde4_bindir}/kwrite
%{_kde4_libdir}/libkdeinit4_kwrite.so
%{_kde4_applicationsdir}/kwrite.desktop
%{_kde4_appsdir}/kwrite/

%files -n kwrite-doc
%defattr(-,root,root,-)
%doc %lang(en) %{_kde4_htmldir}/en/kwrite/

%changelog