LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File require-rack-1.1.patch of Package hawk (Project openSUSE:Factory)

Index: hawk/config/environment.rb
===================================================================
--- hawk/config/environment.rb.orig
+++ hawk/config/environment.rb
@@ -36,7 +36,13 @@ Rails::Initializer.run do |config|
   config.gem "locale_rails"
   config.gem "gettext"
   config.gem "gettext_rails"
-  config.gem "rack"
+  # Explicitly require any rack version in the 1.1 series.  This is necessary because
+  # ActionPack 2.3.8 explicitly specifies this as well, so if we run on a system with
+  # rack 1.2, it all breaks horribly if we don't force it back to 1.1 here.  Some further
+  # discussion is at:
+  #   https://rails.lighthouseapp.com/projects/8994/tickets/3685-actionpack-235-gem-declares-incompatibility-with-rack-110
+  #   https://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/5146
+  config.gem "rack", :version => '~> 1.1.0'
 
   # Only load the plugins named here, in the order given (default is alphabetical).
   # :all can be used as a placeholder for all plugins not explicitly named