LogoopenSUSE Build Service > Projects
Sign Up | Log In

security update for postgresql92-libs...

postgresql92: security update to 9.2.3
Description:
  PostgreSQL was updated to version 9.2.3 that fixes bugs
  and a security issue.

  Updated to version 9.2.3:
  * Prevent execution of enum_recv from SQL (Tom Lane) (CVE-2013-0255).
  * Fix multiple problems in detection of when a consistent database
    state has been reached during WAL replay
  * Fix detection of end-of-backup point when no actual redo 
    work is required
  * Update minimum recovery point when truncating a relation file
  * Fix recycling of WAL segments after changing recovery target
    timeline
  * Properly restore timeline history files from archive on
    cascading standby servers
  * Fix lock conflict detection on hot-standby servers
  * Fix missing cancellations in hot standby mode
  * See the release notes for the rest of the changes:
    http://www.postgresql.org/docs/9.2/static/release-9-2-3.html
    /usr/share/doc/packages/postgresql/HISTORY
Fixed bugs:
Required actions:
  • Relogin suggested: Req decline
  • Reboot suggested: Req decline
  • Package-manager restart: Req decline