LogoopenSUSE Build Service > Projects
Sign Up | Log In

Enlightenment 17 and EFL devel project

Devel project of E17 and EFL libraries for openSUSE integration.

Comments for X11:Enlightenment:Factory (3)

Srinidhi B S srinidhi wrote 7 months ago

13.1 repo?

Could someone please add a 13.1 repository for this project? From what I understand Factory isn't 13.1 anymore.

Simon Lees simotek wrote 4 months ago

Done a while ago

Stephan Kulow coolo wrote about 2 months ago

the errors become more complex at least :)

package enlightenment-theme-openSUSE-20131230-56.1.noarch requires enlightenment, but none of the providers can be installed
package enlightenment-0.18.2-10.1.x86_64 requires enlightenment-branding = 0.1, but none of the providers can be installed
package e17-branding-openSUSE-0.1-28.1.x86_64 requires enlightenment-theme-openSUSE, but none of the providers can be installed
package e17-branding-openSUSE-0.1-28.1.x86_64 conflicts with namespace:otherproviders(enlightenment-branding) provided by enlightenment-branding-openSUSE-0.1-20.1.x86_64
package enlightenment-branding-openSUSE-0.1-20.1.x86_64 conflicts with namespace:otherproviders(e17-branding) provided by e17-branding-openSUSE-0.1-28.1.x86_64
package e17-branding-openSUSE-0.1-28.1.x86_64 conflicts with namespace:otherproviders(enlightenment-branding) provided by enlightenment-branding-upstream-0.18.2-10.1.x86_64
package enlightenment-branding-upstream-0.18.2-10.1.x86_64 conflicts with namespace:otherproviders(e17-branding) provided by e17-branding-openSUSE-0.1-28.1.x86_64

Simon Lees simotek wrote about 2 months ago

Big error, Simple Solution.
enlightenment-theme shouldn't depend on enlightenment i will fix that

because e17 depends on enlightenment-theme through elementary e17 pulls in enlightenment theme as it should

however, enlightenment theme trys to pull in enlightenment and enlightenment branding, which conflicts with all other branding hence all the errors above.

Stephan Kulow coolo wrote about 2 months ago

I honestly don't know why these problems appear one after the other, but:

nothing provides pkgconfig(edbus) >= 1.7.10 needed by e17-devel-0.17.6-61.1.x86_64
(we have e_dbus-devel-1.7.8-4.2.x86_64)
nothing provides pkgconfig(ehal) >= 1.7.10 needed by e17-devel-0.17.6-61.1.x86_64
(we have e_dbus-devel-1.7.8-4.2.x86_64)
nothing provides pkgconfig(eukit) >= 1.7.10 needed by e17-devel-0.17.6-61.1.x86_64
(we have e_dbus-devel-1.7.8-4.2.x86_64)

Simon Lees simotek wrote about 2 months ago

woops mustn't have hit reply this morning.

It is weird that that has only decided to be a issue now. I've pushed e_dbus 1.7.10 to Factory which should hopefully fix it. Do you see these errors on installation or somewhere else?

Stephan Kulow coolo wrote about 2 months ago

this is the repo checker's installcheck. It simulates installation of the submitted packages on factory.