File python3-pymongo.spec of Package python-pymongo
#
# spec file for package python3-pymongo
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python3-pymongo
Version: 2.4.1
Release: 0
Url: http://github.com/mongodb/mongo-python-driver
Summary: Python driver for MongoDB
License: Apache-2.0
Group: Development/Languages/Python
Source: http://pypi.python.org/packages/source/p/pymongo/pymongo-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: python3
BuildRequires: python3-2to3
BuildRequires: python3-devel
BuildRequires: python3-distribute
#BuildRequires: python-nose
Suggests: mongodb
%if %{?suse_version} <= 1140
%define python3_sitearch /usr/lib64/python3.1/site-packages
%endif
%description
The PyMongo distribution contains tools for interacting with MongoDB
database from Python. The bson package is an implementation of
the BSON format for Python. The pymongo package is a native Python
driver for MongoDB. The gridfs package is a gridfs
implementation on top of pymongo.
%prep
%setup -q -n pymongo-%{version}
%build
2to3 .
CFLAGS="%{optflags}" python3 setup.py build
%install
python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
#%%check
#python setup.py test
%files
%defattr(-,root,root,-)
%doc LICENSE README.rst
%{python3_sitearch}/*
%changelog