File python-pymongo.spec of Package python-pymongo
#
# spec file for package python-pymongo
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-pymongo
Version: 2.6.2
Release: 0
Url: http://github.com/mongodb/mongo-python-driver
Summary: Python driver for MongoDB
License: Apache-2.0
Group: Development/Languages/Python
Source: http://pypi.python.org/packages/source/p/pymongo/pymongo-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: python-devel
BuildRequires: python-setuptools
#BuildRequires: python-nose
Suggests: mongodb
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitearch: %global python_sitearch %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%endif
%description
The PyMongo distribution contains tools for interacting with MongoDB
database from Python. The bson package is an implementation of
the BSON format for Python. The pymongo package is a native Python
driver for MongoDB. The gridfs package is a gridfs
implementation on top of pymongo.
%prep
%setup -q -n pymongo-%{version}
%build
CFLAGS="%{optflags}" python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
#%%check
#python setup.py test
%files
%defattr(-,root,root,-)
%doc LICENSE README.rst
%ifarch %{ix86} x86_64 %{arm} aarch64
%{python_sitearch}/*
%else
%{python_sitelib}/*
%endif
%changelog