File python-pycadf.spec of Package python-pycadf
#
# spec file for package python-pycadf
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-pycadf
Version: 0.5.1
Release: 0
Summary: DMTF Cloud Audit (CADF) data mode
License: Apache-2.0
Group: Development/Languages/Python
Url: https://launchpad.net/pycadf
Source: https://pypi.python.org/packages/source/p/pycadf/pycadf-%{version}.tar.gz
BuildRequires: python-devel
BuildRequires: python-pbr
# Test dependencies
BuildRequires: python-Babel >= 1.3
BuildRequires: python-WebOb >= 1.2.3
BuildRequires: python-fixtures >= 0.3.14
BuildRequires: python-iso8601 >= 0.1.8
BuildRequires: python-mock >= 1.0
BuildRequires: python-mox >= 0.5.3
BuildRequires: python-netaddr >= 0.7.6
BuildRequires: python-oslo.config >= 1.2.0
BuildRequires: python-oslo.messaging
BuildRequires: python-python-subunit >= 0.0.18
BuildRequires: python-six >= 1.4.1
BuildRequires: python-testrepository >= 0.0.17
BuildRequires: python-testscenarios >= 0.4
BuildRequires: python-testtools >= 0.9.34
Requires: python-Babel >= 1.3
Requires: python-WebOb >= 1.2.3
Requires: python-iso8601 >= 0.1.8
Requires: python-netaddr >= 0.7.6
Requires: python-oslo.config >= 1.2.0
Requires: python-oslo.messaging >= 1.3.0a4
Requires: python-pytz >= 2010h
Requires: python-six >= 1.4.1
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
BuildRequires: python-discover
%else
BuildArch: noarch
%endif
%description
Python implementation of DMTF Cloud Audit (CADF) data mode.
%prep
%setup -q -n pycadf-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
##### FIXME
mkdir -p %{buildroot}/etc
mv %{buildroot}/usr/etc/pycadf %{buildroot}/etc
%check
testr init && testr run --parallel
%files
%defattr(-,root,root,-)
%doc ChangeLog README.rst LICENSE AUTHORS
%{_sysconfdir}/pycadf
%{python_sitelib}/*
%changelog