File python-docker-py.spec of Package python-docker-py
#
# spec file for package python-docker-py
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define upstream_name docker-py
Name: python-docker-py
Version: 0.5.3
Release: 0
Summary: Docker API Client
License: Apache-2.0
Group: System/Management
Url: https://github.com/dotcloud/docker-py
Source0: %{upstream_name}-%{version}.tar.gz
# openSUSE-Patch hide_py_pckgmgmt.patch
Patch0: hide_py_pckgmgmt.patch
Patch1: dockpyTest_pathAdd.patch
Requires: python-requests >= 2.2.1
Requires: python-six >= 1.3.0
Requires: python-websocket-client >= 0.11.0
BuildRequires: fdupes
BuildRequires: python-coverage
BuildRequires: python-mock
BuildRequires: python-requests
BuildRequires: python-setuptools
BuildRequires: python-six
BuildRequires: python-websocket-client
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
A docker API client in Python
%package test
Summary: Unit tests
Group: Development/Languages/Python
Requires: python-coverage
Requires: python-mock
Requires: python-requests
Requires: python-setuptools
Requires: python-six
Requires: python-websocket-client
%description test
Unit tests for docker-py
%prep
%setup -q -n %{upstream_name}-%{version}
%patch0
%patch1
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
cp -r tests %{buildroot}/%{python_sitelib}/docker
%fdupes %{buildroot}
%check
python tests/test.py
%files
%defattr(-,root,root,-)
%doc LICENSE README.md
%dir %{python_sitelib}/*
%exclude %{python_sitelib}/docker/tests/
%{python_sitelib}/docker/*
%{python_sitelib}/*egg-info/*
%files test
%defattr(-,root,root,-)
%dir %{python_sitelib}/docker/tests
%{python_sitelib}/docker/tests/*
%changelog