File python-WSME.spec of Package python-WSME
#
# spec file for package python-WSME
#
# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-WSME
Version: 0.6.4
Release: 0
Summary: Web Services Made Easy
License: MIT
Group: Development/Languages/Python
Url: http://packages.python.org/WSME/
Source: http://pypi.python.org/packages/source/W/WSME/WSME-%{version}.tar.gz
BuildRequires: python-devel
BuildRequires: python-pbr >= 0.5.21
BuildRequires: python-setuptools
BuildRequires: python-six
# Test requirements:
BuildRequires: python-WebOb
BuildRequires: python-ipaddr
BuildRequires: python-simplegeneric
Requires: python-WebOb
Requires: python-ipaddr
Requires: python-simplegeneric
Requires: python-six
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
BuildRequires: python-ordereddict
Requires: python-ordereddict
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
Web Service Made Easy (WSME) is a very easy way to implement webservices
in your python web application.
It is originally a rewrite of TGWebServices
with focus on extensibility, framework-independance and better type handling.
%prep
%setup -q -n WSME-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%check
python setup.py test
%files
%defattr(-,root,root,-)
%doc LICENSE README.rst examples
%{python_sitelib}/*
%changelog