File python-keystonemiddleware.spec of Package python-keystonemiddleware
#
# spec file for package python-keystonemiddleware
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-keystonemiddleware
Version: 1.5.1
Release: 0
Summary: Middleware for OpenStack Identity
License: Apache-2.0
Group: Development/Languages/Python
Url: http://launchpad.net/keystonemiddleware
Source: https://pypi.python.org/packages/source/k/keystonemiddleware/keystonemiddleware-%{version}.tar.gz
BuildRequires: python-WebOb
BuildRequires: python-coverage
BuildRequires: python-devel
BuildRequires: python-fixtures
BuildRequires: python-keystoneclient
BuildRequires: python-lxml
BuildRequires: python-oslotest
BuildRequires: python-pbr
BuildRequires: python-requests
BuildRequires: python-requests-mock
BuildRequires: python-six
BuildRequires: python-testrepository
BuildRequires: python-testresources
BuildRequires: python-testtools
# Test requirements
BuildRequires: python-memcached
BuildRequires: python-mock
BuildRequires: python-pycrypto
Requires: python-Babel >= 1.3
Requires: python-WebOb >= 1.2.3
Requires: python-iso8601 >= 0.1.9
Requires: python-keystoneclient >= 1.1.0
Requires: python-oslo.config >= 1.9.0
Requires: python-oslo.context >= 0.2.0
Requires: python-oslo.i18n >= 1.3.0
Requires: python-oslo.messaging >= 1.6.0
Requires: python-oslo.serialization >= 1.2.0
Requires: python-oslo.utils >= 1.2.0
Requires: python-pycadf >= 0.8.0
Requires: python-requests >= 2.2.0
Requires: python-six >= 1.9.0
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
This package contains middleware modules designed to provide authentication and
authorization features to web services other than `Keystone
<https://github.com/openstack/keystone>`. The most prominent module is
``keystonemiddleware.auth_token``. This package does not expose any CLI or
Python API features.
%prep
%setup -q -n keystonemiddleware-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%files
%defattr(-,root,root,-)
%doc AUTHORS LICENSE README.rst ChangeLog
%{python_sitelib}/*
%changelog