File python-pycrypto.spec of Package python-pycrypto
#
# spec file for package python-pycrypto
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-pycrypto
Version: 2.6.1
Release: 0
Url: http://www.pycrypto.org/
Summary: Cryptographic modules for Python
License: Python-2.0
Group: Development/Languages/Python
Source: https://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-%{version}.tar.gz
# PATCH-FIX-SUSE: We don't have libgmp5 on SLE11
Patch0: ignore-fastmath-warning.diff
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: gmp-devel
BuildRequires: python-devel
Provides: python-crypto = %{version}
Obsoletes: python-crypto < %{version}
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitearch: %global python_sitearch %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%endif
%description
The package contains:
* Hash functions: MD2, MD4, RIPEMD, SHA256.
* Block encryption algorithms: AES, ARC2, Blowfish, CAST, DES,
Triple-DES, IDEA, RC5.
* Stream encryption algorithms: ARC4, simple XOR.
* Public-key algorithms: RSA, DSA, ElGamal, qNEW.
* Protocols: All-or-nothing transforms, chaffing/winnowing.
* Miscellaneous: RFC1751 module for converting 128-key keys into a
set of English words, primality testing.
* Some demo programs (currently all quite old and outdated).
%prep
%setup -q -n pycrypto-%{version}
%if 0%{?suse_version} < 1120
%patch0
%endif
%build
CFLAGS="%{optflags} -fno-strict-aliasing" python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%check
python setup.py test
%files
%defattr(-,root,root)
%doc ACKS ChangeLog COPYRIGHT README
%{python_sitearch}/Crypto/
%{python_sitearch}/pycrypto-%{version}-py*.egg-info
%changelog