File python-Jinja2.spec of Package python-Jinja2
#
# spec file for package python-Jinja2
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-Jinja2
Version: 2.7.3
Release: 0
Summary: A fast and easy to use template engine written in pure Python
License: BSD-3-Clause
Group: Development/Languages/Python
Url: http://jinja.pocoo.org/
Source: http://pypi.python.org/packages/source/J/Jinja2/Jinja2-%{version}.tar.gz
BuildRequires: fdupes
BuildRequires: python-MarkupSafe
BuildRequires: python-devel
BuildRequires: python-setuptools
Provides: python-jinja2 = %{version}
Obsoletes: python-jinja2 < %{version}
Requires: python-MarkupSafe
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
Jinja2 is a template engine written in pure Python. It provides a Django
inspired non-XML syntax but supports inline expressions and an optional
sandboxed environment. Here a small example of a Jinja template:
{% extends 'base.html' %}
{% block title %}Memberlist{% endblock %}
{% block content %}
<ul>
{% for user in users %}
<li><a href="{{ user.url }}">{{ user.username }}</a></li>
{% endfor %}
</ul>
{% endblock %}
%package vim
Summary: Jinja2 syntax files for Vim
License: BSD-3-Clause
Group: Productivity/Text/Editors
Requires: %{name} = %{version}
%if 0%{?suse_version} >= 1010
Recommends: vim
%endif
%description vim
Vim syntax highlighting scheme for Jinja2 templates.
%package emacs
Summary: Jinja2 syntax files for Emacs
License: GPL-2.0+
Group: Productivity/Text/Editors
Requires: %{name} = %{version}
%if 0%{?suse_version} >= 1010
Recommends: emacs
%endif
%description emacs
Emacs syntax highlighting scheme for Jinja2 templates.
%prep
%setup -q -n Jinja2-%{version}
%build
python setup.py build
sed -i 's/\r$//' LICENSE # Fix wrong EOL encoding
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
install -Dm644 ext/Vim/jinja.vim %{buildroot}%{_datadir}/vim/site/syntax/jinja.vim # Install VIM syntax file
install -Dm644 ext/jinja.el %{buildroot}%{_datadir}/emacs/site-lisp/jinja.el # Install Emacs syntax file
%if 0%{?suse_version}
%fdupes %{buildroot}%{_prefix}
%endif
%check
python run-tests.py
%files
%defattr(-,root,root,-)
%doc AUTHORS CHANGES LICENSE artwork examples
%{python_sitelib}/jinja2
%{python_sitelib}/Jinja2-%{version}-py%{py_ver}.egg-info
%files vim
%defattr(-,root,root,-)
%dir %{_datadir}/vim
%dir %{_datadir}/vim/site
%dir %{_datadir}/vim/site/syntax
%{_datadir}/vim/site/syntax/jinja.vim
%files emacs
%defattr(-,root,root,-)
%{_datadir}/emacs/site-lisp/jinja.el
%changelog