File python-tempest-lib.spec of Package python-tempest-lib
#
# spec file for package python-tempest-lib
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-tempest-lib
Version: 0.11.0
Release: 0
Summary: OpenStack Functional Testing Library
License: Apache-2.0
Group: Development/Languages/Python
Url: http://www.openstack.org/
Source: https://pypi.python.org/packages/source/t/tempest-lib/tempest-lib-%{version}.tar.gz
Patch0: 0001-Allow-passing-insecure-to-python-client-binaries.patch
BuildRequires: python-devel
BuildRequires: python-pbr
BuildRequires: python-setuptools
# test requirements
BuildRequires: python-coverage
BuildRequires: python-ddt
BuildRequires: python-discover
BuildRequires: python-httplib2
BuildRequires: python-jsonschema
BuildRequires: python-mock
BuildRequires: python-oslo.log
BuildRequires: python-oslosphinx
BuildRequires: python-oslotest
BuildRequires: python-paramiko
BuildRequires: python-python-subunit
BuildRequires: python-sphinx
BuildRequires: python-testrepository
BuildRequires: python-testscenarios
BuildRequires: python-testtools
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Requires: python-Babel >= 1.3
Requires: python-fixtures >= 1.3.1
Requires: python-httplib2 >= 0.7.5
Requires: python-iso8601 >= 0.1.9
Requires: python-jsonschema >= 2.0.0
Requires: python-os-testr >= 0.4.1
Requires: python-oslo.log >= 1.8.0
Requires: python-six >= 1.9.0
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
OpenStack Functional Testing Library
%prep
%setup -q -n tempest-lib-%{version}
%patch0 -p1
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%check
testr init && testr run --parallel
%files
%defattr(-,root,root,-)
%doc README.rst ChangeLog LICENSE AUTHORS
%{_bindir}/skip-tracker
%{_bindir}/check-uuid
%{python_sitelib}/*
%changelog