File python-oslo.db.spec of Package python-oslo.db
#
# spec file for package python-oslo.db
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%global sname oslo.db
Name: python-oslo.db
Version: 4.13.6
Release: 0
Summary: OpenStack oslo.db library
License: Apache-2.0
Group: Development/Languages/Python
Url: https://launchpad.net/%{sname}
Source0: https://pypi.io/packages/source/o/%{sname}/%{sname}-%{version}.tar.gz
BuildRequires: openstack-macros
BuildRequires: python-MySQL-python
BuildRequires: python-PyMySQL >= 0.6.2
BuildRequires: python-alembic >= 0.8.4
BuildRequires: python-debtcollector >= 1.2.0
BuildRequires: python-devel
BuildRequires: python-eventlet >= 0.18.2
BuildRequires: python-fixtures >= 3.0.0
BuildRequires: python-mock >= 2.0
BuildRequires: python-oslo.config >= 3.14.0
BuildRequires: python-oslo.context >= 2.9.0
BuildRequires: python-oslo.i18n >= 2.1.0
BuildRequires: python-oslo.utils >= 3.16.0
BuildRequires: python-oslotest >= 1.10.0
BuildRequires: python-pbr >= 1.6
BuildRequires: python-psycopg2 >= 2.5
BuildRequires: python-python-subunit >= 0.0.18
BuildRequires: python-reno >= 1.8.0
BuildRequires: python-six >= 1.9.0
BuildRequires: python-sqlalchemy-migrate >= 0.9.6
BuildRequires: python-testrepository >= 0.0.18
BuildRequires: python-testresources >= 0.2.4
BuildRequires: python-testscenarios >= 0.4
BuildRequires: python-testtools >= 1.4.0
Requires: python-PyMySQL >= 0.6.2
Requires: python-SQLAlchemy >= 1.0.10
Requires: python-alembic >= 0.8.4
Requires: python-debtcollector >= 1.2.0
Requires: python-oslo.config >= 3.14.0
Requires: python-oslo.context >= 2.9.0
Requires: python-oslo.i18n >= 2.1.0
Requires: python-oslo.utils >= 3.16.0
Requires: python-psycopg2 >= 2.5
Requires: python-six >= 1.9.0
Requires: python-sqlalchemy-migrate >= 0.9.6
Requires: python-stevedore >= 1.16.0
BuildArch: noarch
%description
The OpenStack Oslo database handling library. Provides database connectivity
to the different backends and helper utils.
* Documentation: http://docs.openstack.org/developer/oslo.db
* Source: http://git.openstack.org/cgit/openstack/oslo.db
* Bugs: http://bugs.launchpad.net/oslo
%package doc
Summary: Documentation for the Oslo database handling library
Group: Documentation
BuildRequires: python-Sphinx
BuildRequires: python-oslosphinx >= 2.5.0
%description doc
Documentation for the Oslo database handling library.
%prep
%setup -q -n %{sname}-%{version}
%build
%{py2_build}
# generate html docs
%{__python2} setup.py build_sphinx
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%install
%{py2_install}
%check
%{__python2} setup.py testr
%files
%license LICENSE
%doc README.rst ChangeLog
%{python2_sitelib}/oslo_db
%{python2_sitelib}/*.egg-info
%files doc
%license LICENSE
%doc doc/build/html
%changelog