File python-docker-py.spec of Package python-docker-py
#
# spec file for package python-docker-py
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define upstream_name docker-py
Name: python-docker-py
Version: 1.10.6
Release: 0
Summary: Docker API Client
License: Apache-2.0
Group: System/Management
Url: https://pypi.python.org/pypi/docker-py
Source0: https://files.pythonhosted.org/packages/source/d/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
# openSUSE-Patch hide_py_pckgmgmt.patch
Patch0: hide_py_pckgmgmt.patch
Requires: python-backports.ssl_match_hostname >= 3.5
Requires: python-docker-pycreds >= 0.2.1
Requires: python-ipaddress >= 1.0.16
Requires: python-requests >= 2.5.3
Requires: python-six >= 1.4.0
Requires: python-websocket-client >= 0.32.0
BuildRequires: fdupes
BuildRequires: python-mock
BuildRequires: python-pytest
BuildRequires: python-pytest-cov
BuildRequires: python-requests
BuildRequires: python-setuptools
BuildRequires: python-six
BuildRequires: python-websocket-client
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
A docker API client in Python
%package test
Summary: Unit tests
Group: Development/Languages/Python
Requires: %{name} == %{version}
Requires: python-coverage >= 3.7.1
Requires: python-flake8 >= 2.4.1
Requires: python-mock >= 1.0.1
Requires: python-pytest >= 2.7.2
Requires: python-pytest-cov >= 2.1.0
Requires: python-setuptools
%description test
Unit tests for docker-py
%prep
%setup -q -n %{upstream_name}-%{version}
%patch0 -p1
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
cp -r tests %{buildroot}/%{python_sitelib}/docker
%fdupes %{buildroot}
%check
#python tests/test.py
%files
%defattr(-,root,root,-)
%doc LICENSE README.md
%dir %{python_sitelib}/*
%exclude %{python_sitelib}/docker/tests/
%{python_sitelib}/docker/*
%{python_sitelib}/*egg-info/*
%files test
%defattr(-,root,root,-)
%dir %{python_sitelib}/docker/tests
%{python_sitelib}/docker/tests/*
%changelog