File python-botocore.spec of Package python-botocore

#
# spec file for package python-botocore
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-botocore
Version:        1.5.89
Release:        0
Summary:        Python interface for AWS
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            https://github.com/boto/botocore
Source0:        https://files.pythonhosted.org/packages/source/b/botocore/botocore-%{version}.tar.gz
Patch0:         hide_py_pckgmgmt.patch
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module docutils >= 0.10}
BuildRequires:  %{python_module jmespath < 1.0.0}
BuildRequires:  %{python_module jmespath >= 0.7.1}
BuildRequires:  %{python_module python-dateutil <= 3.0.0}
BuildRequires:  %{python_module python-dateutil >= 2.1}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
# Testing requirements
%if %{with tests}
BuildRequires:  %{python_module nose}
BuildRequires:  python-mock
BuildRequires:  python-unittest2
%endif
Requires:       python-docutils   >= 0.10
Requires:       python-jmespath   < 1.0.0
Requires:       python-jmespath   >= 0.7.1
Requires:       python-python-dateutil   <= 3.0.0
Requires:       python-python-dateutil   >= 2.1
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
%python_subpackages

%description
A low-level interface to a growing number of Amazon Web Services.

%prep
%setup -q -n  botocore-%{version}
%patch0 -p1

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%if %{with tests}
%check
%python_expand nosetests-%{$python_bin_suffix} tests/unit
%endif

%files %{python_files}
%defattr(-,root,root,-)
%doc LICENSE.txt README.rst
%{python_sitelib}/botocore/
%{python_sitelib}/botocore-%{version}-py%{py_ver}.egg-info

%changelog
openSUSE Build Service is sponsored by