File python-monascaclient.spec of Package python-monascaclient
#
# spec file for package python-monascaclient
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-monascaclient
Version: 2.4.0
Release: 0
Summary: Python API and CLI for OpenStack Monasca
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/python-monascaclient
Source0: https://files.pythonhosted.org/packages/source/p/python-monascaclient/python-monascaclient-2.4.0.tar.gz
BuildRequires: openstack-macros
BuildRequires: python39-PrettyTable
BuildRequires: python39-PyYAML
BuildRequires: python39-fixtures
BuildRequires: python39-mock
BuildRequires: python39-openstackdocstheme
BuildRequires: python39-osc-lib
BuildRequires: python39-oslo.concurrency
BuildRequires: python39-oslo.serialization
BuildRequires: python39-oslo.utils
BuildRequires: python39-oslotest
BuildRequires: python39-pbr
BuildRequires: python39-stestr
BuildRequires: python39-testscenarios
BuildRequires: python39-testtools
BuildArch: noarch
%description
This is a client library for Monasca built to interface with the Monasca API. It
provides a Python API (the ``monascaclient`` module) and a command-line tool
(``monasca``).
%package -n python3-monascaclient
Summary: Python API and CLI for OpenStack Monasca
Requires: python39-Babel
Requires: python39-PrettyTable
Requires: python39-PyYAML
Requires: python39-iso8601
Requires: python39-osc-lib
Requires: python39-oslo.serialization
Requires: python39-oslo.utils
Requires: python39-pbr
Requires: python39-requests
Requires: python39-six
%if 0%{?suse_version}
Obsoletes: python2-monascaclient < 2.0.0
%endif
%description -n python3-monascaclient
This is a client library for Monasca built to interface with the Monasca API. It
provides a Python API (the ``monascaclient`` module) and a command-line tool
(``monasca``).
The Monasca Client was written using the OpenStack Heat Python client as a framework.
%prep
%autosetup -p1 -n python-monascaclient-2.4.0
%py_req_cleanup
%build
%{py3_build}
%install
%{py3_install}
%check
python3 -m stestr.cli run
%files -n python3-monascaclient
%doc README.rst
%license LICENSE
%{python3_sitelib}/monascaclient
%{python3_sitelib}/*.egg-info
%{_bindir}/monasca
%changelog