File python-os-resource-classes.spec of Package python-os-resource-classes
#
# spec file for package python-os-resource-classes
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-os-resource-classes
Version: 1.1.0
Release: 0
Summary: Resource Classes for OpenStack
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/os-resource-classes
Source0: https://files.pythonhosted.org/packages/source/o/os-resource-classes/os-resource-classes-1.1.0.tar.gz
BuildRequires: openstack-macros
BuildRequires: python39-oslotest
BuildRequires: python39-pbr
BuildRequires: python39-stestr
BuildRequires: python39-testtools
BuildArch: noarch
%description
A list of standardized resource classes for OpenStack.
A resource class is a distinct type of inventory that exists in a cloud
environment, for example VCPU, DISK_GB. They are upper case with underscores.
They often include a unit in their name.
This package provides a collection of symbols representing those standard
resource classes which are expected to be available in any OpenStack deployment.
There also exists a concept of custom resource classes. These are countable
types that are custom to a particular environment. The OpenStack placement
API provides a way to create these. A custom resource class always begins
with a CUSTOM_ prefix.
%package -n python39-os-resource-classes
Summary: Resource Classes for OpenStack
Requires: python39-pbr
%description -n python39-os-resource-classes
A list of standardized resource classes for OpenStack.
A resource class is a distinct type of inventory that exists in a cloud
environment, for example VCPU, DISK_GB. They are upper case with underscores.
They often include a unit in their name.
This package provides a collection of symbols representing those standard
resource classes which are expected to be available in any OpenStack deployment.
There also exists a concept of custom resource classes. These are countable
types that are custom to a particular environment. The OpenStack placement
API provides a way to create these. A custom resource class always begins
with a CUSTOM_ prefix.
This package contains the Python 3.x module
%package -n python-os-resource-classes-doc
Summary: Documentation for Resource Classes for OpenStack
Group: Documentation/HTML
BuildRequires: python39-Sphinx
BuildRequires: python39-openstackdocstheme
%description -n python-os-resource-classes-doc
A list of standardized resource classes for OpenStack.
A resource class is a distinct type of inventory that exists in a cloud
environment, for example VCPU, DISK_GB. They are upper case with underscores.
They often include a unit in their name.
This package provides a collection of symbols representing those standard
resource classes which are expected to be available in any OpenStack deployment.
There also exists a concept of custom resource classes. These are countable
types that are custom to a particular environment. The OpenStack placement
API provides a way to create these. A custom resource class always begins
with a CUSTOM_ prefix.
This package contains the documentation.
%prep
%autosetup -p1 -n os-resource-classes-1.1.0
%py_req_cleanup
%build
%{py3_build}
PBR_VERSION=1.1.0 %sphinx_build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%install
%{py3_install}
%check
python3 -m stestr.cli run
%files -n python39-os-resource-classes
%doc README.rst ChangeLog
%license LICENSE
%{python3_sitelib}/os_resource_classes*
%{python3_sitelib}/*.egg-info
%files -n python-os-resource-classes-doc
%doc doc/build/html
%license LICENSE
%changelog