File python-oslo.utils.spec of Package python-oslo.utils
#
# spec file for package python-oslo.utils
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-oslo.utils
Version: 4.13.0
Release: 0
Summary: OpenStack Utils Library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/oslo.utils
Source0: https://files.pythonhosted.org/packages/source/o/oslo.utils/oslo.utils-4.13.0.tar.gz
BuildRequires: openstack-macros
BuildRequires: python39-Babel
BuildRequires: python39-ddt
BuildRequires: python39-debtcollector
BuildRequires: python39-eventlet
BuildRequires: python39-fixtures
BuildRequires: python39-iso8601
BuildRequires: python39-mock
BuildRequires: python39-monotonic
BuildRequires: python39-netaddr
BuildRequires: python39-netifaces
BuildRequires: python39-oslo.i18n
BuildRequires: python39-oslotest
BuildRequires: python39-pbr
BuildRequires: python39-pyparsing
BuildRequires: python39-stestr
BuildRequires: python39-testscenarios
BuildRequires: python39-testtools
BuildArch: noarch
%description
The oslo.utils library provides support for common utility type functions,
such as encoding, exception handling, string manipulation, and time handling.
%package -n python39-oslo.utils
Summary: OpenStack Utils Library
Requires: python39-debtcollector
Requires: python39-iso8601
Requires: python39-netaddr
Requires: python39-netifaces
Requires: python39-oslo.i18n
Requires: python39-pyparsing
Requires: python39-pytz
%description -n python39-oslo.utils
The oslo.utils library provides support for common utility type functions,
such as encoding, exception handling, string manipulation, and time handling.
This package contains the Python 3.x module.
%package -n python-oslo.utils-doc
Summary: Documentation for OpenStack utils library
BuildRequires: python39-Sphinx
BuildRequires: python39-openstackdocstheme
%description -n python-oslo.utils-doc
Documentation for OpenStack utils library.
%prep
%autosetup -p1 -n oslo.utils-4.13.0
%py_req_cleanup
%build
%py3_build
%install
%py3_install
# generate html docs
PBR_VERSION=4.13.0 %sphinx_build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%check
# tests fail with python 3.8
rm -v oslo_utils/tests/test_reflection.py
python3 -m stestr.cli run
%files -n python39-oslo.utils
%license LICENSE
%doc ChangeLog README.rst
%{python3_sitelib}/oslo_utils
%{python3_sitelib}/*.egg-info
%files -n python-oslo.utils-doc
%doc doc/build/html
%license LICENSE
%changelog