File python-taskflow.spec of Package python-taskflow
#
# spec file for package python-taskflow
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-taskflow
Version: 4.6.2
Release: 0
Summary: Taskflow structured state management library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/taskflow
Source0: https://files.pythonhosted.org/packages/source/t/taskflow/taskflow-4.6.2.tar.gz
BuildRequires: openstack-macros
BuildRequires: python39-PyMySQL
BuildRequires: python39-SQLAlchemy
BuildRequires: python39-SQLAlchemy-Utils
BuildRequires: python39-alembic
BuildRequires: python39-automaton
BuildRequires: python39-cachetools
BuildRequires: python39-eventlet
BuildRequires: python39-fasteners
BuildRequires: python39-futurist
BuildRequires: python39-jsonschema
BuildRequires: python39-kazoo
BuildRequires: python39-kombu
BuildRequires: python39-networkx
BuildRequires: python39-oslo.serialization
BuildRequires: python39-oslo.utils
BuildRequires: python39-oslotest
BuildRequires: python39-pbr
BuildRequires: python39-psycopg2
BuildRequires: python39-pydot
BuildRequires: python39-redis
BuildRequires: python39-retrying
BuildRequires: python39-stestr
BuildRequires: python39-stevedore
BuildRequires: python39-tenacity
BuildRequires: python39-testrepository
BuildRequires: python39-testscenarios
BuildRequires: python39-testtools
BuildRequires: python39-zake
BuildArch: noarch
%description
A library to do [jobs, tasks, flows] in a HA manner using
different backends to be used with OpenStack projects.
%package -n python3-taskflow
Summary: Taskflow structured state management library
Requires: python39-automaton
Requires: python39-cachetools
Requires: python39-debtcollector
Requires: python39-fasteners
Requires: python39-futurist
Requires: python39-jsonschema
Requires: python39-kazoo
Requires: python39-networkx
Requires: python39-oslo.serialization
Requires: python39-oslo.utils
Requires: python39-six
Requires: python39-stevedore
Requires: python39-tenacity
%description -n python3-taskflow
A library to do [jobs, tasks, flows] in a HA manner using
different backends to be used with OpenStack projects.
This package contains the Python 3.x module.
%package -n python-taskflow-doc
Summary: Documentation for Taskflow
Group: Documentation/HTML
BuildRequires: python39-Sphinx
BuildRequires: python39-openstackdocstheme
%description -n python-taskflow-doc
A library to do [jobs, tasks, flows] in a HA manner using
different backends to be used with OpenStack projects.
This package contains the associated documentation.
%prep
%autosetup -p1 -n taskflow-4.6.2
%py_req_cleanup
%build
%{py3_build}
%install
%{py3_install}
# generate html docs
PBR_VERSION=4.6.2 %sphinx_build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%check
python3 -m stestr.cli run
%files -n python3-taskflow
%doc README.rst
%license LICENSE
%{python3_sitelib}/taskflow
%{python3_sitelib}/taskflow-*.egg-info
%files -n python-taskflow-doc
%license LICENSE
%doc doc/build/html
%changelog