File sblim-cmpi-sysfs.spec of Package sblim-cmpi-sysfs

#
# spec file for package sblim-cmpi-sysfs (Version 1.1.9)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           sblim-cmpi-sysfs
BuildRequires:  gcc-c++ openslp-devel openssl-devel pam-devel sblim-cmpi-base-devel sblim-indication_helper-devel sblim-testsuite
Url:            http://sblim.wiki.sourceforge.net/
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Summary:        SBLIM Linux Sysfs Instrumentation for CMPI
Version:        1.1.9
Release:        86
Group:          System/Management
License:        IBM Public License
Requires:       sblim-cmpi-base >= 1.2.3, cim-server
Source0:        http://prdownloads.sourceforge.net/sblim/sblim-cmpi-sysfs-%{version}.tar.bz2
PreReq:         sblim-sfcb
#!BuildIgnore:  tog-pegasus

%description
This package provides SBLIM instrumentation to expose the kernel
devices accessible via sysfs, which is a virtual filesystem in Linux
kernel versions 2.5+ that provides a tree of system devices. The sysfs
filesystem is mounted under /sys and the various subdirectories of /sys
represent the different classes of devices currently registered on the
machine.



Authors:
--------
    SBLIM Project

%prep
%setup -q -n %{name}-%{version}

%build
%configure --disable-static
%{__make}

%install
%makeinstall docdir=%{_docdir}/%{name}
rm %buildroot%_libdir/cmpi/*.la
rm %buildroot%_libdir/*.la

%clean
%{__rm} -rf $RPM_BUILD_ROOT

%post
%define mofs Linux_SysfsAttribute,Linux_SysfsBlockDevice,Linux_SysfsBusDevice,Linux_SysfsInputDevice,Linux_SysfsNetworkDevice,Linux_SysfsSCSIDevice,Linux_SysfsSCSIHostDevice,Linux_SysfsTTYDevice
# compile MOF
d=%_datadir/%name
$d/provider-register.sh -t sfcb -r $d/{%{mofs}}.registration -m $d/{%{mofs}}.mof

%preun 
if [ "$1" = "0" ]; then
	d=%_datadir/%name
	$d/provider-register.sh -t sfcb -d -r $d/{%{mofs}}.registration -m $d/{%{mofs}}.mof
fi

%files
%defattr(-,root,root)
# skip-check-libtool-deps
%{_libdir}/cmpi/*.so
%{_libdir}/*.so
%{_datadir}/sblim-testsuite
%{_datadir}/%{name}
%doc %{_docdir}/%{name}

%changelog
* Tue May 12 2009 mhrusecky@suse.cz
- ignoring tog-pegasus during the build
* Thu Jan 08 2009 mhrusecky@suse.cz
- registering everything in one step to prevent unnecessary sfcb
  restarts
* Fri Sep 12 2008 mmarek@suse.cz
- switch to sfcb
* Thu Nov 01 2007 mmarek@suse.cz
- updated to 1.1.9
  fixed upstream bugs:
  * 1199129 Providers won't compile with CMPI 1.0
  * 1430899 Loop in sysfs provider on newer /sys
  * 1532575 cmpi-sysfs: seg fault if file contains hex data
  * 1533889 cmpi-sysfs: find options in the wrong order
- removed static libs
* Tue Jan 16 2007 mrueckert@suse.de
- added sblim-cmpi-sysfs-1.1.8_Linux_SysfsAttributeUtil.c.makeinstance.patch:
  check for nonprintable data and return NULL in case (#192299)
* Tue Mar 07 2006 mrueckert@suse.de
- added sblim-cmpi-sysfs-1.1.7_sysfs_no_follow.patch
  sysfs contains cyclic symlinks. the provider uses find(1) to
  traversal the tree. the patch fixes the find call so it wont
  loop infinitely anymore. (#154863)
* Thu Mar 02 2006 mrueckert@suse.de
- update to 1.1.8 [#144214]
- dropped all patches as the build system has changed
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Tue Dec 13 2005 mrueckert@suse.de
- update to 1.1.7
- build with openwbem
- build with optflags
- use new loadmof/rmmof syntax
* Thu Nov 11 2004 ro@suse.de
- fixed file list
* Thu May 20 2004 nashif@suse.de
- fix #40890: provider fails to read file/dir names that contain
  spaces
- V. 1.1.3
* Wed May 12 2004 nashif@suse.de
- Do not De-register when updating package
* Mon May 10 2004 nashif@suse.de
- Dereigster providers when uninstalling (#39667)
- test scripts incorrectly check file read/write permission (#40262)
* Fri Apr 30 2004 nashif@suse.de
- Update to version 1.1.1
- fixes bug #39032: util libs installed in wrong directory
* Wed Apr 14 2004 nashif@suse.de
- Added PreReq for loadmof.sh
* Wed Apr 07 2004 nashif@suse.de
- Initial version
openSUSE Build Service is sponsored by