File dragonplayer.spec of Package dragonplayer
#
# spec file for package dragonplayer
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define kf6_version 6.6.0
%define qt6_version 6.6.0
%define rname dragon
%bcond_without released
Name: dragonplayer
Version: 24.12.1
Release: 0
Summary: Multimedia Player
License: GPL-2.0-or-later
URL: https://apps.kde.org/dragonplayer
Source0: https://download.kde.org/stable/release-service/%{version}/src/%{rname}-%{version}.tar.xz
%if %{with released}
Source1: https://download.kde.org/stable/release-service/%{version}/src/%{rname}-%{version}.tar.xz.sig
Source2: applications.keyring
%endif
BuildRequires: kf6-extra-cmake-modules >= %{kf6_version}
BuildRequires: cmake(KF6Config) >= %{kf6_version}
BuildRequires: cmake(KF6ConfigWidgets) >= %{kf6_version}
BuildRequires: cmake(KF6CoreAddons) >= %{kf6_version}
BuildRequires: cmake(KF6Crash) >= %{kf6_version}
BuildRequires: cmake(KF6DBusAddons) >= %{kf6_version}
BuildRequires: cmake(KF6DocTools) >= %{kf6_version}
BuildRequires: cmake(KF6I18n) >= %{kf6_version}
BuildRequires: cmake(KF6JobWidgets) >= %{kf6_version}
BuildRequires: cmake(KF6KIO) >= %{kf6_version}
BuildRequires: cmake(KF6Parts) >= %{kf6_version}
BuildRequires: cmake(KF6Solid) >= %{kf6_version}
BuildRequires: cmake(KF6WidgetsAddons) >= %{kf6_version}
BuildRequires: cmake(KF6WindowSystem) >= %{kf6_version}
BuildRequires: cmake(KF6XmlGui) >= %{kf6_version}
BuildRequires: cmake(Phonon4Qt6)
BuildRequires: cmake(Qt6Core) >= %{qt6_version}
BuildRequires: cmake(Qt6Widgets) >= %{qt6_version}
%description
Dragon Player is a simple video player.
%lang_package
%prep
%autosetup -p1 -n %{rname}-%{version}
%build
%cmake_kf6
%kf6_build
%install
%kf6_install
# Obsolete icons, breeze is the default theme
rm -r %{buildroot}%{_kf6_iconsdir}/oxygen
%find_lang %{name} --with-man --with-html --all-name
%ldconfig_scriptlets
%files
%license LICENSES/*
%doc %lang(en) %{_kf6_htmldir}/en/dragonplayer/
%{_kf6_configdir}/dragonplayerrc
%{_kf6_applicationsdir}/org.kde.dragonplayer.desktop
%{_kf6_appstreamdir}/org.kde.dragonplayer.appdata.xml
%{_kf6_bindir}/dragon
%{_kf6_iconsdir}/hicolor/*/apps/dragonplayer.*
%{_kf6_mandir}/man1/dragon.1%{?ext_man}
%{_kf6_plugindir}/kf6/parts/dragonpart.so
%dir %{_kf6_sharedir}/kio
%dir %{_kf6_sharedir}/kio/servicemenus
%{_kf6_sharedir}/kio/servicemenus/dragonplayer_play_dvd.desktop
%dir %{_kf6_sharedir}/solid
%dir %{_kf6_sharedir}/solid/actions
%{_kf6_sharedir}/solid/actions/dragonplayer-openaudiocd.desktop
%{_kf6_sharedir}/solid/actions/dragonplayer-opendvd.desktop
%files lang -f %{name}.lang
%exclude %{_kf6_htmldir}/en/dragonplayer/
%changelog