File gegl.spec of Package gegl.4314

#
# spec file for package gegl
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           gegl
# Patched code is built by default.
# Use rpmbuild -D 'BUILD_ORIG 1' to build original code.
# Use rpmbuild -D 'BUILD_ORIG 1' -D 'BUILD_ORIG_ADDON 1' to build patched build plus original as addon.
BuildRequires:  ImageMagick
BuildRequires:  OpenEXR-devel
BuildRequires:  SDL-devel
BuildRequires:  asciidoc
BuildRequires:  babl-devel >= 0.1.10
BuildRequires:  enscript
BuildRequires:  gcc-c++
BuildRequires:  glib2-devel >= 2.16.1
BuildRequires:  graphviz-gd
BuildRequires:  gtk2-devel
BuildRequires:  intltool
BuildRequires:  lensfun-devel
# Needed to build the doc, as Bitstream Vera Sans is the referenced font.
BuildRequires:  liberation-fonts
BuildRequires:  libexiv2-devel
BuildRequires:  libjasper-devel >= 1.900.1
BuildRequires:  libjpeg-devel
BuildRequires:  libopenraw-devel >= 0.0.5
BuildRequires:  libpng-devel
BuildRequires:  librsvg-devel
BuildRequires:  libspiro-devel
BuildRequires:  libstdc++-devel
BuildRequires:  lua-devel
BuildRequires:  ruby
# For umfpack
BuildRequires:  suitesparse-devel
# Only for directory ownership:
BuildRequires:  gtk-doc
%if 0%{?BUILD_ORIG}
BuildRequires:  ffmpeg-devel
%if 0%{?BUILD_ORIG_ADDON}
Provides:       patched_subset
%else
Provides:       %{name}-orig-addon = %{version}
Obsoletes:      %{name}-orig-addon
%endif
%else
Provides:       patched_subset
%endif
Url:            http://gegl.org/
Version:        0.2.0
Release:        0
Summary:        Generic Graphics Library
License:        GPL-3.0+ and LGPL-3.0+
Group:          System/Libraries
Source:         http://ftp.gtk.org/pub/gegl/0.2/%{name}-%{version}.tar.bz2
# PATCH-FIX-UPSTREAM gegl-lua52.patch bgo#667675 vuntz@opensuse.org -- Fix build with lua 5.2
Patch0:         gegl-lua52.patch
# PATCH-FIX-UPSTREAM gegl-ruby19.patch dimstar@opensuse.org -- Fix build with ruby 1.9
Patch1:         gegl-ruby19.patch
# PATCH-FIX-SECURITY gegl-0.2.0-CVE-2012-4433.patch bsc789835 CVE-2012-4433 zaitor@opensuse.org -- Fix buffer overflow in and add plausibility checks to ppm-load op
Patch4:         gegl-0.2.0-CVE-2012-4433.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%define debug_package_requires libgegl-0_2-0 = %{version}-%{release}

%description
GEGL provides infrastructure to do demand based cached non destructive
image editing on larger than RAM buffers. Through babl it provides
support for a wide range of color models and pixel storage formats for
input and output.

%package 0_2
Summary:        Generic Graphics Library
Group:          System/Libraries
Recommends:     %{name}-0_2-lang

%description 0_2
GEGL provides infrastructure to do demand based cached non destructive
image editing on larger than RAM buffers. Through babl it provides
support for a wide range of color models and pixel storage formats for
input and output.

%if 0%{?BUILD_ORIG}
%if 0%{?BUILD_ORIG_ADDON}

%package 0_2-orig-addon
Summary:        Generic Graphics Library
Group:          System/Libraries
Supplements:    packageand(%{name}-0_2:%(cd %{_libdir} ; rpm -qf --queryformat=%%{NAME} `readlink %{_libdir}/libavcodec.so` ))

%description 0_2-orig-addon
GEGL provides infrastructure to do demand based cached non destructive
image editing on larger than RAM buffers. Through babl it provides
support for a wide range of color models and pixel storage formats for
input and output.

%endif
%endif

%package -n libgegl-0_2-0
Summary:        Generic Graphics Library
Group:          System/Libraries
Recommends:     %{name}-0_2 >= %{version}

%description -n libgegl-0_2-0
GEGL provides infrastructure to do demand based cached non destructive
image editing on larger than RAM buffers. Through babl it provides
support for a wide range of color models and pixel storage formats for
input and output.

%package devel
Summary:        Generic Graphics Library
Group:          System/Libraries
Requires:       babl-devel
Requires:       glib2-devel
Requires:       glibc-devel
Requires:       libgegl-0_2-0 = %{version}
Requires:       pcre-devel

%description devel
GEGL provides infratructure to do demand based cached non destructive
image editing on larger than RAM buffers. Through babl it provides
support for a wide range of color models and pixel storage formats for
input and output.

%package doc
Summary:        Generic Graphics Library
Group:          System/Libraries
Requires:       libgegl-0_2-0 = %{version}

%description doc
GEGL provides infrastructure to do demand based cached non destructive
image editing on larger than RAM buffers. Through babl it provides
support for a wide range of color models and pixel storage formats for
input and output.

%lang_package -n %{name}-0_2
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch4 -p1
# docs-build-fix.diff

%build
export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
## do not use autogen.sh, it intentionally fails, if there is no ruby. 
## so why use autogen, when you do not want portability?
# ./autogen.sh
%configure\
	--enable-workshop=yes\
	--disable-static --disable-silent-rules
make %{?jobs:-j%jobs}

%install
%makeinstall
%if ! 0%{?BUILD_ORIG}
for MODULE in \
%{_libdir}/gegl-0.2/ff-load.so \
; do
    rm -f $RPM_BUILD_ROOT$MODULE
done
%endif
find %{buildroot} -type f -name "*.la" -delete -print
%find_lang %{name}-0.2 %{?no_lang_C}

%post -n libgegl-0_2-0 -p /sbin/ldconfig

%postun -n libgegl-0_2-0 -p /sbin/ldconfig

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%{_bindir}/gegl

%files 0_2
%defattr(-,root,root)
%dir %{_libdir}/gegl-0.2/
%{_libdir}/gegl-0.2/*.so
%if 0%{?BUILD_ORIG}
%if 0%{?BUILD_ORIG_ADDON}
%exclude %{_libdir}/gegl-0.2/ff-load.so

%files 0_2-orig-addon
%defattr(-,root,root)
%{_libdir}/gegl-0.2/ff-load.so
%endif
%endif

%files -n libgegl-0_2-0
%defattr(-,root,root)
%doc AUTHORS COPYING COPYING.LESSER ChangeLog NEWS README
%{_libdir}/libgegl-0.2.so.*

%files devel
%defattr(-,root,root)
%{_includedir}/gegl-0.2/
%{_libdir}/libgegl-0.2.so
%{_libdir}/pkgconfig/gegl-0.2.pc

%files doc
%defattr(-,root,root)
%doc %{_datadir}/gtk-doc/html/gegl/

%files -n %{name}-0_2-lang -f %{name}-0.2.lang

%changelog
openSUSE Build Service is sponsored by