File nvme-cli.spec of Package nvme-cli.7759

#
# spec file for package nvme-cli
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           nvme-cli
Version:        1.5
Release:        0
Summary:        NVM Express user space tools
License:        GPL-2.0-only
Group:          Hardware/Other
Url:            https://github.com/linux-nvme/nvme-cli
Source:         %{name}-v%{version}.tar.gz
BuildRequires:  asciidoc
BuildRequires:  libuuid-devel
BuildRequires:  xmlto
BuildRequires:  pkgconfig(libudev)
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Patch1:         0001-nvme-cli-add-NetApp-plugin.patch
Patch2:         0002-nvme-cli-add-netapp-smdevices-man-page.patch
Patch3:         0003-get-log-Make-log-identifier-a-required-parameter.patch
Patch4:         0004-Documentation-add-manpage-entry-for-connect-s-ctrl-l.patch
Patch5:         0005-fabrics-add-option-to-supply-keep-alive-timeout-for.patch
Patch6:         0006-fabrics-add-ctrl-loss-tmo-to-connect-all.patch
Patch7:         0007-nvme-vendor-Add-get-log-LSP-LSO-fields-from-1.3-spec.patch
Patch8:         0008-nvme-cli-Implement-nvme_get_log13.patch
Patch9:         0009-nvme-cli-Add-support-of-unsigned-long-long-to-json-r.patch
Patch10:        0010-nvme-cli-add-support-of-RAE.patch
Patch11:        0011-nvme-cli-add-minimal-ana-log-page-support.patch
Patch12:        0012-nvme-cli-add-ana-log-documentation.patch
Patch13:        0013-nvme-discover-sanitize-options.patch
Patch14:        0014-Fix-double-free-in-list_subsys.patch
Patch15:        0015-Log-error-incase-of-failure-in-get_nvme_subsystem_in.patch
Patch16:        0016-nvme-cli-move-print-function-to-nvme-print.patch
Patch17:        0017-nvme-cli-show-partial-results-if-controller-fails-du.patch
Patch18:        0018-nvme-list-subsys-Add-device-name-argument-and-print-.patch
Patch19:        0019-nvme-discover-Retry-discovery-log-if-the-generation-.patch
Patch20:        0020-nvme-cli-fabrics-Fix-passing-host_traddr-for-all-tra.patch
Patch21:        0021-fabrics-write-ctrl_loss_tmo-to-fabrics-device-on-con.patch
patch22:        0022-fabrics-write-keep-alive-timeout-to-fabrics-device-o.patch

%description
NVM Express (NVMe) is a direct attached storage interface. The
nvme-cli package contains core management tools with minimal
dependencies.

%prep
%setup -q -n %{name}-v%{version}
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1
%patch14 -p1
%patch15 -p1
%patch16 -p1
%patch17 -p1
%patch18 -p1
%patch19 -p1
%patch20 -p1
%patch21 -p1
%patch22 -p1

%build
echo %{version} > version
make CFLAGS="%{optflags}" PREFIX=%{_prefix} %{?_smp_mflags} all

%install
make PREFIX=%{_prefix} DESTDIR=%{buildroot} install-bin install-man %{?_smp_mflags}
install -m 644 -D /dev/null %{buildroot}%{_sysconfdir}/nvme/hostnqn
install -m 644 -D completions/bash-nvme-completion.sh %{buildroot}%{_sysconfdir}/bash_completion.d/nvme

%post
if [ ! -e %{_sysconfdir}/nvme/hostnqn ]; then
	%{_sbindir}/nvme gen-hostnqn > %{_sysconfdir}/nvme/hostnqn
fi
if [ ! -e %{_sysconfdir}/nvme/hostid ]; then
	%{_bindir}/uuidgen > %{_sysconfdir}/nvme/hostid
fi

%files
%defattr(-,root,root)
%doc README.md LICENSE
%{_sbindir}/nvme
%{_mandir}/man1/nvme*.1*
%dir %{_sysconfdir}/bash_completion.d/
%{_sysconfdir}/bash_completion.d/nvme
%dir %{_sysconfdir}/nvme/
%ghost %{_sysconfdir}/nvme/hostnqn
%ghost %{_sysconfdir}/nvme/hostid 

%changelog
openSUSE Build Service is sponsored by