File openssl-ibmca.spec of Package openssl-ibmca.31145

#
# spec file for package openssl-ibmca
#
# Copyright (c) 2018-2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#

%define flavor @BUILD_FLAVOR@%{nil}
%global enginesdir %(pkg-config --variable=enginesdir libcrypto)
%global modulesdir %(pkg-config --variable=modulesdir libcrypto)
%if "%flavor" == "openssl3"
%global sslengcnf %{_sysconfdir}/ssl/engines3.d
%global sslengdef %{_sysconfdir}/ssl/engdef3.d
%else
%global sslengcnf %{_sysconfdir}/ssl/engines.d
%global sslengdef %{_sysconfdir}/ssl/engdef.d
%endif

%if "%{flavor}" == "openssl3"
Name:           openssl3-ibmca
%else
Name:           openssl-ibmca
%endif
Version:        2.4.0
Release:        0
Summary:        The IBMCA OpenSSL dynamic engine
License:        Apache-2.0
Group:          Hardware/Other
URL:            https://github.com/opencryptoki/openssl-ibmca
Source:         https://github.com/opencryptoki/openssl-ibmca/archive/v%{version}.tar.gz#/openssl-ibmca-%{version}.tar.gz
Source1:        engine_section.txt
###
Patch001:	openssl-ibmca-engine-noregister.patch
%if "%flavor" == "openssl3"
Patch002:	openssl3-rename-libica-files.patch
%endif
###
BuildRequires:  autoconf
BuildRequires:  automake
BuildRequires:  libtool
%if "%flavor" == "openssl3"
BuildRequires:  libica4-openssl3 >= 4.0.1
BuildRequires:  libica-openssl3-devel >= 4.0.1
BuildRequires:  libica-openssl3-tools >= 4.0.1
BuildRequires:  libopenssl-3-devel
BuildRequires:  openssl-3
Requires:       libica4-openssl3 >= 4.0.1
Requires:       openssl-3
%else
BuildRequires:  libica >= 4.0.0
BuildRequires:  libica-devel >= 4.0.0
BuildRequires:  libica-tools >= 4.0.0
BuildRequires:  openssl-devel
Requires:       libica4 >= 4.0.0
Requires:       openssl
%endif
ExclusiveArch:  s390x

%description
This package contains a shared object OpenSSL dynamic engine which interfaces
to libica, a library enabling the IBM s390/x CPACF crypto instructions.

%prep
%autosetup -p1 -n openssl-ibmca-%{version}
./bootstrap.sh

%build
export CFLAGS="%{optflags}"
export CPPFLAGS="%{optflags}"
%if "%flavor" == "openssl3"
export LIBICA_SHARED_LIB=%{_libdir}/libica-openssl3.so.4
%endif
%configure \
    --libdir=%{enginesdir}
%make_build

%install
# Update the sample config file so that the dynamic path points
# to the correct version of the engines directory.
sed -i -e "/^dynamic_path/s, = .*/, = %{enginesdir}/," src/engine/openssl.cnf.sample

%make_install
rm %{buildroot}%{enginesdir}/ibmca.la

# This file contains the declaration of the ibmca engine section. It
# needs to be on the "real" file system when the postinstall scriptlet
# is run. It will be read by the openssl .include directive that points
# to /etc/ssl/engines.d/
mkdir -p %{buildroot}%{_datadir}/%{name}
cp -p %{SOURCE1} %{buildroot}%{_datadir}/%{name}/openssl-ibmca.sectiondef.txt

# This will create the actual engine definition section that will be usable
# by the .include directive of openSSL. That include will be inserted during
# the postinstall phase of the package installation.
grep -v "^#" src/engine/openssl.cnf.sample | \
    sed -n -e '/^\[ibmca_section\]/,$ p' | \
    sed -e '/^$/ {N;N;s/\n\n/\n/g;}' | \
    sed -e 's/^dynamic_path/#dynamic_path/' > %{buildroot}%{_datadir}/%{name}/openssl-ibmca.enginedef.cnf

#Create the engines cnf and def directories
mkdir -p %{buildroot}%{sslengcnf}
mkdir -p %{buildroot}%{sslengdef}

%if "%flavor" == "openssl3"
mv %{buildroot}%{_mandir}/man5/{ibmca,%{name}}.5
mv %{buildroot}%{_mandir}/man5/{ibmca,%{name}}-provider.5
%endif

%post
#Original fix for bsc#942839 was to update on first install
#For bsc#966139 update if openssl_def not found
cp -p %{_datadir}/%{name}/openssl-ibmca.sectiondef.txt %{sslengcnf}/openssl-ibmca.cnf
cp -p %{_datadir}/%{name}/openssl-ibmca.enginedef.cnf %{sslengdef}/openssl-ibmca.cnf

%postun
if [ $1 -eq 0 ]; then # last uninstall
  rm -f %{sslengcnf}/openssl-ibmca.cnf
  rm -f %{sslengdef}/openssl-ibmca.cnf
fi

%files
%license LICENSE
%doc ChangeLog
%doc README.md
%doc src/engine/openssl.cnf.sample
%doc src/engine/ibmca-engine-opensslconfig
%dir %{_datadir}/%{name}
%{_datadir}/%{name}/openssl-ibmca.sectiondef.txt
%{_datadir}/%{name}/openssl-ibmca.enginedef.cnf
%{enginesdir}/ibmca{,-provider}.*
%{_mandir}/man5/*.5%{?ext_man}

%changelog
openSUSE Build Service is sponsored by