File decentxml.spec of Package decentxml.28016
#
# spec file for package decentxml
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: decentxml
Version: 1.4
Release: 0
Summary: XML parser optimized for round-tripping and code reuse
License: BSD-3-Clause
Group: Development/Libraries/Java
URL: http://code.google.com/p/%{name}
Source0: https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/decentxml/decentxml-1.4-src.zip
# for running w3c conformance test suite
Source1: http://www.w3.org/XML/Test/xmlts20031210.zip
BuildRequires: fdupes
BuildRequires: java-devel >= 1.8
BuildRequires: maven-local
BuildRequires: unzip
BuildRequires: mvn(org.apache.maven.plugins:maven-assembly-plugin)
BuildRequires: mvn(org.apache.maven.plugins:maven-source-plugin)
BuildArch: noarch
%description
XML parser optimized for round-tripping and code reuse with main
features being:
* Allows 100%% round-tripping, even for weird whitespace between
attributes in the start tag or in the end tag
* Suitable for building editors and filters which want/need to
preserve the original file layout as much as possible
* Error messages have line and column information
* XML 1.1 compatible
%package javadoc
Summary: API documentation for %{name}
Group: Documentation/HTML
%description javadoc
This package contains the API documentation for %{name}.
%prep
%setup -q
# we are looking for xml conformance data one lever above so unzip
# here and symlink there
unzip %{SOURCE1}
ln -sf %{name}-%{version}/xmlconf ../xmlconf
sed -i -e "s|junit-dep|junit|g" pom.xml
%pom_remove_plugin :maven-javadoc-plugin
# Don't use deprecated "attached" goal of Maven Assembly Plugin, which
# was removed in version 3.0.0.
%pom_xpath_set "pom:plugin[pom:artifactId='maven-assembly-plugin']/pom:executions/pom:execution/pom:goals/pom:goal[text()='attached']" single
%build
%{mvn_file} : %{name}
%{mvn_build} -f -- \
%if %{?pkg_vcmp:%pkg_vcmp java-devel >= 9}%{!?pkg_vcmp:0}
-Dmaven.compiler.release=8 \
%endif
-Dsource=8
%install
%mvn_install
%fdupes -s %{buildroot}%{_javadocdir}
%files -f .mfiles
%license LICENSE
%doc README
%files javadoc -f .mfiles-javadoc
%license LICENSE
%changelog