File erlang-chef_authn.spec of Package erlang-chef_authn
#
# spec file for package erlang-eper
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: erlang-chef_authn
Version: 0.0.0+git.1354136195.7d230f8
%define mod_ver %(echo "%{version}" | cut -d "+" -f1)
Release: 0
License: Apache-2.0
Summary: This is the authentication layer for chef
Url: http://github.com/opscode/chef_authn/
Group: Development/Libraries/Other
Source: chef_authn-%{version}.tar.gz
Patch01: PATCH-01_eleminate-git-dependency.patch
BuildRequires: erlang-rebar
Requires: erlang
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
This is the authentication layer for chef.
Chef is a system integration framework written in erlang and ruby and designed
to bring the benefits of configuration management to your entire infrastructure.
The Chef Wiki is the definitive source of user documentation.
%package devel
Summary: This is the authentication layer for chef
Group: Development/Libraries/Other
Requires: %{name} = %{version}
Provides: %{name}-src = %{version}
#TODO: Change back to '<' after next version update:
Obsoletes: %{name}-src <= %{version}
%description devel
This is the authentication layer for chef.
Chef is a system integration framework written in erlang and ruby and designed
to bring the benefits of configuration management to your entire infrastructure.
The Chef Wiki is the definitive source of user documentation
%prep
%setup -n chef_authn-%{version}
%patch01 -p1
%build
%rebar compile escriptize
#rebar compile
%install
for dir in ebin src ; do
install -d %{buildroot}%{erlang_libdir}/chef_authn-%{mod_ver}/${dir}
cp -r ${dir}/* %{buildroot}%{erlang_libdir}/chef_authn-%{mod_ver}/${dir}/
done
%files
%defattr(-,root,root)
#%doc README COPYING
%dir %{erlang_libdir}/chef_authn-%{mod_ver}
%{erlang_libdir}/chef_authn-%{mod_ver}/ebin
%files devel
%defattr(-,root,root)
%{erlang_libdir}/chef_authn-%{mod_ver}/src
%changelog