File perl-App-SerializeUtils.spec of Package perl-App-SerializeUtils
#
# spec file for package perl-App-SerializeUtils
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define cpan_name App-SerializeUtils
Name: perl-App-SerializeUtils
Version: 0.165.0
Release: 0
# 0.165 -> normalize -> 0.165.0
%define cpan_version 0.165
License: Artistic-1.0 OR GPL-1.0-or-later
Summary: Utilities for serialization tasks
URL: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/P/PE/PERLANCAR/%{cpan_name}-%{cpan_version}.tar.gz
Source1: cpanspec.yml
BuildArch: noarch
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(Cpanel::JSON::XS)
BuildRequires: perl(Data::Dmp) >= 0.241.0
BuildRequires: perl(Data::Dump)
BuildRequires: perl(Data::Dump::Color) >= 0.246.0
BuildRequires: perl(Data::Dump::SExpression)
BuildRequires: perl(Data::Dumper::Compact)
BuildRequires: perl(Data::Undump)
BuildRequires: perl(Getopt::Long) >= 2.50
BuildRequires: perl(Getopt::Long::Complete)
BuildRequires: perl(JSON::Color)
BuildRequires: perl(JSON::MaybeXS)
BuildRequires: perl(JSON::PP)
BuildRequires: perl(PHP::Serialization)
BuildRequires: perl(SExpression::Decode::Marpa)
BuildRequires: perl(Sereal::Decoder)
BuildRequires: perl(Sereal::Encoder)
BuildRequires: perl(Storable) >= 3.08
BuildRequires: perl(YAML::Old)
BuildRequires: perl(YAML::Syck)
BuildRequires: perl(YAML::Tiny::Color)
BuildRequires: perl(YAML::XS)
Requires: perl(Cpanel::JSON::XS)
Requires: perl(Data::Dmp) >= 0.241.0
Requires: perl(Data::Dump)
Requires: perl(Data::Dump::Color) >= 0.246.0
Requires: perl(Data::Dump::SExpression)
Requires: perl(Data::Dumper::Compact)
Requires: perl(Data::Undump)
Requires: perl(Getopt::Long) >= 2.50
Requires: perl(Getopt::Long::Complete)
Requires: perl(JSON::Color)
Requires: perl(JSON::MaybeXS)
Requires: perl(JSON::PP)
Requires: perl(PHP::Serialization)
Requires: perl(SExpression::Decode::Marpa)
Requires: perl(Sereal::Decoder)
Requires: perl(Sereal::Encoder)
Requires: perl(Storable) >= 3.08
Requires: perl(YAML::Old)
Requires: perl(YAML::Syck)
Requires: perl(YAML::Tiny::Color)
Requires: perl(YAML::XS)
Provides: perl(App::SerializeUtils) = %{version}
%undefine __perllib_provides
%{perl_requires}
%description
This distributions provides the following command-line utilities related to
serialization:
* * check-json
* * check-phpser
* * check-yaml
* * json2json
* * json2perl
* * json2perlcolor
* * json2phpser
* * json2sereal
* * json2sexp
* * json2storable
* * json2yaml
* * perl2json
* * perl2perl
* * perl2perlcolor
* * perl2phpser
* * perl2sereal
* * perl2sexp
* * perl2storable
* * perl2yaml
* * phpser2json
* * phpser2perl
* * phpser2perlcolor
* * phpser2sereal
* * phpser2sexp
* * phpser2storable
* * phpser2yaml
* * pp-json
* * pp-perl
* * pp-yaml
* * sereal2json
* * sereal2perl
* * sereal2perlcolor
* * sereal2phpser
* * sereal2sexp
* * sereal2storable
* * sereal2yaml
* * serializeutils-convert
* * sexp2json
* * sexp2perl
* * sexp2perlcolor
* * sexp2phpser
* * sexp2sereal
* * sexp2storable
* * sexp2yaml
* * storable2json
* * storable2perl
* * storable2perlcolor
* * storable2phpser
* * storable2sereal
* * storable2sexp
* * storable2yaml
* * yaml2json
* * yaml2perl
* * yaml2perlcolor
* * yaml2phpser
* * yaml2sereal
* * yaml2sexp
* * yaml2storabls
* * yaml2yaml
%prep
%autosetup -n %{cpan_name}-%{cpan_version}
find . -type f ! -path "*/t/*" ! -name "*.pl" ! -path "*/bin/*" ! -path "*/script/*" ! -path "*/scripts/*" ! -name "configure" -print0 | xargs -0 chmod 644
%build
perl Makefile.PL INSTALLDIRS=vendor
%make_build
%check
make test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%doc Changes README
%license LICENSE
%changelog