File rubygem-io-like.spec of Package rubygem-io-like
#
# spec file for package rubygem-io-like
#
# Copyright (c) 2020 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
#
# This file was generated with a gem2rpm.yml and not just plain gem2rpm.
# All sections marked as MANUAL, license headers, summaries and descriptions
# can be maintained in that file. Please consult this file before editing any
# of those fields
#
Name: rubygem-io-like
Version: 0.3.1
Release: 0
%define mod_name io-like
%define mod_full_name %{mod_name}-%{version}
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: %{ruby >= 1.8.1}
BuildRequires: %{rubygem gem2rpm}
BuildRequires: %{rubygem rdoc > 3.10}
BuildRequires: ruby-macros >= 5
URL: http://github.com/javanthropus/io-like
Source: https://rubygems.org/gems/%{mod_full_name}.gem
Source1: gem2rpm.yml
Summary: A module which provides the functionality of an IO object to any
License: GPL-3.0-or-later
Group: Development/Languages/Ruby
%description
The IO::Like module provides all of the methods of typical IO implementations
such as File; most importantly the read, write, and seek series of methods. A
class which includes IO::Like needs to provide only a few methods in order to
enable the higher level methods. Buffering is automatically provided by
default
for the methods which normally provide it in IO.
%prep
%build
%install
%gem_install \
--doc-files="LICENSE NEWS.md README.md" \
-f
%gem_packages
%changelog