File coredumper.spec of Package coredumper
#
# spec file for package coredumper
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: coredumper
Version: 1.2.1
Release: 0
Summary: Generate a core dump of a running program without crashing
License: BSD-3-Clause
Group: Development/Libraries
Url: http://goog-coredumper.sourceforge.net
Source0: http://prdownloads.sourceforge.net/goog-coredumper/%{name}-%{version}.tar.bz2
Patch0: dirent-sched-opensuse-12.3.patch
BuildRequires: gcc-c++
BuildRequires: gdb
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
The coredumper library can be compiled into applications to create
core dumps of the running program, without termination. It
supports both single- and multi-threaded core dumps, even if the
kernel doesn't natively support for multi-threaded core files.
%package -n libcoredumper1
Summary: Generate a core dump of a running program without crashing
Group: Development/Libraries
Provides: %{name} = %{version}
Obsoletes: %{name} <= %{version}
%description -n libcoredumper1
The coredumper library can be compiled into applications to create
core dumps of the running program, without termination. It
supports both single- and multi-threaded core dumps, even if the
kernel doesn't natively support for multi-threaded core files.
%package -n libcoredumper-devel
Summary: Generate a core dump of a running program without crashing
Group: Development/Libraries
Requires: glibc-devel
Requires: libcoredumper1 = %{version}
Provides: %{name}-devel = %{version}
Obsoletes: %{name}-devel <= %{version}
%description -n libcoredumper-devel
The coredumper library can be compiled into applications to create
core dumps of the running program, without termination. It
supports both single- and multi-threaded core dumps, even if the
kernel doesn't natively support for multi-threaded core files.
This package contains static and debug libraries and header
files for developing applications that use the coredumper library.
%prep
%setup -q
%patch0
%build
CFLAGS="%{optflags} -fno-strict-aliasing"
CXXFLAGS="%{optflags} -fno-strict-aliasing"
export CFLAGS
export CXXFLAGS
%configure --disable-static --with-pic
make %{?_smp_mflags}
%install
make DESTDIR=%{buildroot} install %{?_smp_mflags}
rm -rf %{buildroot}%{_datadir}/doc/%{name}-%{version}
%check
make %{?_smp_mflags} check || echo "test failed"
%post -n libcoredumper1 -p /sbin/ldconfig
%postun -n libcoredumper1 -p /sbin/ldconfig
%files -n libcoredumper1
%defattr(-,root,root,-)
%{_libdir}/lib*.so.1*
%files -n libcoredumper-devel
%defattr(-,root,root)
%doc examples AUTHORS COPYING ChangeLog README
%doc %{_mandir}/man3/*
%{_libdir}/lib*.so
%exclude %{_libdir}/lib*.la
%dir %{_includedir}/google
%{_includedir}/google/*
%changelog