File syck.spec of Package syck
#
# spec file for package syck
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# git clone git@github.com:indeyets/syck.git
# cd syck && find . -name .git"*" -print0 | xargs -0 rm -rf
Name: syck
Version: 0.70
Release: 0
Summary: Library for reading and writing YAML
License: BSD-3-Clause
Group: Development/Libraries
Url: http://www.whytheluckystiff.net/syck/
Source: syck-%{version}.tar.xz
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: bison
BuildRequires: flex
BuildRequires: libtool
BuildRequires: xz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Syck is an extension for reading and writing YAML swiftly in popular
scripting languages. As Syck loads the YAML, it stores the data directly in
your language's symbol table.
%package -n libsyck0
Summary: Library for reading and writing YAML
Group: Development/Libraries
Provides: %{name} = %{version}
%description -n libsyck0
Syck is an extension for reading and writing YAML swiftly in popular
scripting languages. As Syck loads the YAML, it stores the data directly in
your language's symbol table.
%package -n libsyck-devel
Summary: Development headers Syck a library for reading and writing YAML
Group: Development/Libraries
Requires: glibc-devel
Requires: libsyck0 = %{version}
Provides: %{name}-devel = %{version}
%description -n libsyck-devel
Syck is an extension for reading and writing YAML swiftly in popular
scripting languages. As Syck loads the YAML, it stores the data directly in
your language's symbol table.
%prep
%setup -q
touch NEWS AUTHORS ChangeLog
autoreconf -vi
%build
%configure --disable-static --enable-static=no --with-pic
# uses lex/yacc without deps
make -j1
%install
make DESTDIR=%{buildroot} install %{?_smp_mflags}
%post -n libsyck0 -p /sbin/ldconfig
%postun -n libsyck0 -p /sbin/ldconfig
%files -n libsyck0
%defattr(-, root, root)
%{_libdir}/libsyck.so.*
%files -n libsyck-devel
%defattr(-, root, root)
%doc COPYING README
%{_includedir}/*.h
%{_libdir}/libsyck.so
%exclude %{_libdir}/*.la
%exclude %{_libdir}/*.a
%changelog