File perl-Dist-Zilla-Plugin-AutoVersion-Relative.spec of Package perl-Dist-Zilla-Plugin-AutoVersion-Relative

#
# spec file for package perl-Dist-Zilla-Plugin-AutoVersion-Relative
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define cpan_name Dist-Zilla-Plugin-AutoVersion-Relative
Name:           perl-Dist-Zilla-Plugin-AutoVersion-Relative
Version:        1.1.1
Release:        0
%define cpan_version 1.001001
License:        Artistic-1.0 OR GPL-1.0-or-later
Summary:        Time-Relative versioning
URL:            https://metacpan.org/release/%{cpan_name}
Source0:        https://cpan.metacpan.org/authors/id/K/KE/KENTNL/%{cpan_name}-%{cpan_version}.tar.gz
Source1:        cpanspec.yml
BuildArch:      noarch
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Const::Fast)
BuildRequires:  perl(DateTime) >= 0.50
BuildRequires:  perl(Dist::Zilla) >= 2.10131
BuildRequires:  perl(Dist::Zilla::Plugin::GatherDir)
BuildRequires:  perl(Dist::Zilla::Role::TextTemplate)
BuildRequires:  perl(Dist::Zilla::Role::VersionProvider)
BuildRequires:  perl(Moose) >= 1.09
BuildRequires:  perl(MooseX::StrictConstructor) >= 0.10
BuildRequires:  perl(MooseX::Types::DateTime) >= 0.05
BuildRequires:  perl(MooseX::Types::Moose)
BuildRequires:  perl(Test::DZil)
BuildRequires:  perl(namespace::autoclean) >= 0.09
Requires:       perl(Const::Fast)
Requires:       perl(DateTime) >= 0.50
Requires:       perl(Dist::Zilla) >= 2.10131
Requires:       perl(Dist::Zilla::Role::TextTemplate)
Requires:       perl(Dist::Zilla::Role::VersionProvider)
Requires:       perl(Moose) >= 1.09
Requires:       perl(MooseX::StrictConstructor) >= 0.10
Requires:       perl(MooseX::Types::DateTime) >= 0.05
Requires:       perl(MooseX::Types::Moose)
Requires:       perl(namespace::autoclean) >= 0.09
Provides:       perl(Dist::Zilla::Plugin::AutoVersion::Relative) = %{version}
%undefine       __perllib_provides
Recommends:     perl(Moose) >= 2.000
%{perl_requires}

%description
Time-Relative versioning

%prep
%autosetup  -n %{cpan_name}-%{cpan_version}

%build
perl Makefile.PL INSTALLDIRS=vendor
%make_build

%check
make test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%doc Changes README
%license LICENSE

%changelog
openSUSE Build Service is sponsored by