File kongress.spec of Package kongress
# spec file for kongress
#
# Copyright (c) 2021 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
%bcond_with lang
Name: kongress
Version: 22.04
Release: 0
License: GPL-3.0-or-later
Summary: Companion application for conferences
Url: https://invent.kde.org/utilities/kongress
Source0: kongress-%{version}.tar.xz
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: cmake
BuildRequires: fdupes
BuildRequires: AppStream
BuildRequires: extra-cmake-modules
BuildRequires: hicolor-icon-theme
BuildRequires: update-desktop-files
BuildRequires: cmake(Qt5DBus)
BuildRequires: cmake(Qt5Core)
BuildRequires: cmake(Qt5Quick)
BuildRequires: cmake(Qt5Gui)
BuildRequires: cmake(Qt5Svg)
BuildRequires: cmake(Qt5Qml)
BuildRequires: cmake(Qt5QuickControls2)
BuildRequires: cmake(Qt5Network)
BuildRequires: cmake(Qt5Widgets)
BuildRequires: cmake(KF5Config)
BuildRequires: cmake(KF5Kirigami2)
BuildRequires: cmake(KF5I18n)
BuildRequires: cmake(KF5CalendarCore)
BuildRequires: cmake(KF5CoreAddons)
BuildRequires: cmake(KF5DBusAddons)
BuildRequires: cmake(KF5Notifications)
BuildRequires: cmake(KF5Service)
Requires: kirigami2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Kongress provides practical information about conferences.
It supports conferences that offer their schedule in iCalendar
format. In Kongress, the data of the talks are shown in various
ways, e.g. in daily views, by talk category, etc. The users can
also create a list of favorite conference talks/events as well as
they can navigate to the web page of each talk. A map of the
conference venue, location information and link to OpenStreetMap
can also be added.
%lang_package
%prep
%setup -q -n kongress-%{version}
%build
%cmake_kf5 -d build -- -DREMINDERS_ENABLED=ON
%cmake_build
%install
%kf5_makeinstall -C build
%kf5_post_install
%fdupes %{buildroot}%{_prefix}
%if %{with lang}
%find_lang %{name}
%endif
%if %{with lang}
%files lang -f %{name}.lang
%endif
%files
%defattr(-,root,root,-)
%doc README.md changelog.md
%license LICENSES/*
%{_kf5_bindir}/{%{name},%{name}ac}
%{_kf5_applicationsdir}/*.desktop
%{_kf5_appstreamdir}/*.appdata.xml
%{_kf5_iconsdir}/*/*/*/*.svg
%{_kf5_sharedir}/dbus-1/services/*
%{_kf5_notifydir}/*.notifyrc
%changelog