File python-multiprocess.spec of Package python-multiprocess
#
# spec file for package python-multiprocess
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-multiprocess
Version: 0.70.16
Release: 0
Summary: better multiprocessing and multithreading in Python
License: BSD-3-Clause
URL: https://github.com/uqfoundation/multiprocess
Source: https://files.pythonhosted.org/packages/source/m/multiprocess/multiprocess-%{version}.tar.gz
BuildRequires: python-rpm-macros
BuildRequires: %{python_module pip}
BuildRequires: %{python_module wheel}
BuildRequires: %{python_module setuptools >= 42}
# SECTION test requirements
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module testsuite}
BuildRequires: %{python_module dill >= 0.3.8}
# /SECTION
BuildRequires: fdupes
Requires: python-dill >= 0.3.8
BuildArch: noarch
%python_subpackages
%description
multiprocess is a fork of multiprocessing.
multiprocess extends multiprocessing to provide enhanced serialization, using dill.
multiprocess leverages multiprocessing to support the spawning of processes using the API of the Python standard library's threading module.
multiprocessing has been distributed as part of the standard library since Python 2.6.
multiprocess is part of pathos, a Python framework for heterogeneous computing.
multiprocess is in active development, so any user feedback, bug reports, comments, or suggestions are highly appreciated.
%prep
%autosetup -p1 -n multiprocess-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%{python_expand #
export PYTHONPATH=./py%{$python_version}:%{buildroot}/%{$python_sitelib}
$python py%{$python_version}/multiprocess/tests/__main__.py
}
%files %{python_files}
%doc README.md
%license COPYING LICENSE
%{python_sitelib}/_multiprocess
%{python_sitelib}/multiprocess
%{python_sitelib}/multiprocess-%{version}.dist-info
%changelog