File rubygem-eventmachine-le.spec of Package rubygem-eventmachine-le

# gem2rpm -t rubygem-eventmachine-le.spec.template eventmachine-le-*.gem -o rubygem-eventmachine-le.spec
#
# spec file for package rubygem-eventmachine-le
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           rubygem-eventmachine-le
Version:        1.1.6
Release:        0
%define mod_name eventmachine-le
%define mod_full_name %{mod_name}-%{version}

BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  ruby-macros >= 3
Requires:       ruby >= 1.8.7
BuildRequires:  ruby >= 1.8.7
BuildRequires:  ruby-devel
BuildRequires:  rubygem(rdoc) > 3.10
BuildRequires:  gcc-c++
Url:            https://github.com/ibc/EventMachine-LE/
Source:         http://rubygems.org/gems/%{mod_full_name}.gem
Summary:        EventMachine LE (Live Edition)
License:        Ruby and GPL
Group:          Development/Languages/Ruby

%description
EventMachine-LE (Live Edition) is a branch of EventMachine
(https://github.com/eventmachine/eventmachine).
This branch incorporates interesting pull requests that are not yet included
in the mainline EventMachine repository. The maintainers of that version
prefer to minimize change in order to keep the stability with already existing
EventMachine deployments, which provides an impressive multi-platform base for
IPv4 TCP servers (e.g., Web servers) that don't need good UDP or IPv6 support.
This dedication to stability is helpful for production use, but can also lead
to ossification. The present "Live Edition" or "Leading Edge" branch has its
focus on supporting a somewhat wider use, including new Web servers or
protocols beyond the HTTP Web.
To provide even more focus, this branch is currently applying its energy
towards Linux and Unix/BSD/OSX environments. Java reactor and pure Ruby
reactor are for now removed in this branch, and Windows/Cygwin support is
untested. This may very well change later, once interesting pull requests come
in.
EventMachine-LE draws from a number of dormant pull requests on the mainline
version of EventMachine. New proposals will also directly come to
EventMachine-LE and will be included once they are tested.
This is not a "development branch", EventMachine-LE is ready for production,
just beyond the focus of mainline EventMachine.

%package doc
Summary:        RDoc documentation for %{mod_name}
Group:          Development/Languages/Ruby
Requires:       %{name} = %{version}

%description doc
Documentation generated at gem installation time.
Usually in RDoc and RI formats.

%prep
#gem_unpack
#if you need patches, apply them here and replace the # with a % sign in the surrounding lines
#gem_build

%build

%install
%gem_install -f --no-rdoc
%gem_cleanup
mkdir -p %{buildroot}%{_docdir}/%{name}
ln -s %{gem_base}/gems/%{mod_full_name}/LICENSE %buildroot/%{_docdir}/%{name}/LICENSE
ln -s %{gem_base}/gems/%{mod_full_name}/README.md %buildroot/%{_docdir}/%{name}/README.md
find %{buildroot}%{gem_base}/gems/%{mod_full_name}/ext -name \*.c -o -name \*.cpp -o -name \*.h | xargs rm -f

%files
%defattr(-,root,root,-)
%{_docdir}/%{name}
%{gem_base}/cache/%{mod_full_name}.gem
%{gem_base}/gems/%{mod_full_name}/
%{gem_extensions}/%{mod_full_name}
%{gem_base}/specifications/%{mod_full_name}.gemspec

%files doc
%defattr(-,root,root,-)
%doc %{gem_base}/doc

%changelog
openSUSE Build Service is sponsored by