File python-jupyter_kernel_test.spec of Package python-jupyter_kernel_test
#
# spec file for package python-jupyter_kernel_test
#
# Copyright (c) 2020 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%define skip_python2 1
%define commit f33ca3bdea9b0b46526bb7385752760f0ca6d736
Name: python-jupyter_kernel_test
Version: 0.3+git24.f33ca3b
Release: 0
Summary: Machinery for testing Jupyter kernels via the messaging protocol
License: BSD-3-Clause
Group: Development/Languages/Python
URL: https://github.com/jupyter/jupyter_kernel_test
Source: %{url}/archive/%{commit}.tar.gz#/%{name}-%{version}.tar.gz
BuildRequires: %{python_module flit}
BuildRequires: %{python_module pip}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: jsonschema
Requires: python-jupyter-kernel-mgmt >= 0.3
Requires: python-jupyter-protocol
Provides: python-jupyter-kernel-test = %{version}-%{release}
BuildArch: noarch
# SECTION test requirements
BuildRequires: %{python_module ipykernel}
BuildRequires: %{python_module jsonschema}
BuildRequires: %{python_module jupyter-kernel-mgmt >= 0.3}
BuildRequires: %{python_module jupyter-protocol}
BuildRequires: %{python_module pytest}
# /SECTION
%if "%{python_flavor}" == "python3" || "%{?python_provides}" == "python3"
Provides: jupyter-jupyter_kernel_test = %{version}-%{release}
%endif
%python_subpackages
%description
jupyter_kernel_test is a tool for testing Jupyter kernels.
It tests kernels for successful code execution and
conformance with the Jupyter Messaging Protocol
(currently 5.0).
%prep
%setup -q -n jupyter_kernel_test-%{commit}
%build
%pyproject_wheel
%install
%pyproject_install
%check
#%%pyunittest test_ipykernel.py -v
%pytest test_ipykernel.py
%files %{python_files}
%license LICENSE
%doc READMES.rst
%{python_sitelib}/jupyter_kernel_test/
%{python_sitelib}/jupyter_kernel_test-%{version}*-info
%changelog