File powerline-rs.spec of Package powerline-rs

#
# spec file for package powerline-rs
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#

%global rustflags '-Clink-arg=-Wl,-z,relro,-z,now'

Name:           powerline-rs
Version:        0.2.0
Release:        0
Summary:        Powerline-shell rewritten in Rust
License:        MIT 
URL:            https://gitlab.com/jD91mZM2/powerline-rs 
Source0:        %{url}-rs/-/archive/%{version}/powerline-rs-%{version}.tar.gz 
Source1:        vendor.tar.xz
Source2:        cargo_config
BuildRequires:  rust-packaging 

%description
A statusline for bash/fish/ion/zsh written in rust, similar to powerline-shell

%prep
%setup -qa1
mkdir .cargo
cp %{SOURCE2} .cargo/config

%build
RUSTFLAGS=%{rustflags} cargo build --release


%install
RUSTFLAGS=%{rustflags} cargo install --root=%{buildroot}%{_prefix} --path .
# remove residue crate file
rm -f %{buildroot}%{_prefix}/.crates*

%post
%postun

%files
%license LICENSE 
%doc README.org
%{_bindir}/powerline-rs

%changelog

openSUSE Build Service is sponsored by